Closed Bug 1593290 Opened 4 months ago Closed 3 months ago

Turn on personalization for DS

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 72
Iteration:
72.2 - Nov 4 - 17
Tracking Status
firefox71 + verified
firefox72 + verified

People

(Reporter: thecount, Assigned: thecount)

References

Details

(Keywords: github-merged)

Attachments

(2 files)

After a smoke test in nightly with personalization on, we have a high level of confidence that this is low risk now.

Should just be a pref flip.

Assignee: nobody → sdowne

[Tracking Requested - why for this release]:

Iteration: --- → 72.2 - Nov 4 - 17
Priority: -- → P1
Blocks: 1595901
Status: NEW → RESOLVED
Closed: 3 months ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

I have verified that the personalization is successfully turned on for DS using the latest Firefox Nightly (72.0a1 Build ID - 20191114055112) installed, on Windows 10 x64, Arch Linux and Mac 10.15.1, using the steps Scott provided here.

Status: RESOLVED → VERIFIED

Comment on attachment 9109683 [details]
Bug 1593290 - Turn on personalization for DS

Beta/Release Uplift Approval Request

  • User impact if declined: Revenue impact to spocs
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Steps to test:
  1. Create a brand new profile.
  2. Visit all these sites...

http://softpedia.com
http://speedtest.net
http://chip.de
http://cultofmac.com
http://majorgeeks.com
http://9to5mac.com
http://tomshardware.com
http://xda-developers.com
http://sourceforge.net
http://pcmag.com
http://techradar.com
http://tomsguide.com
http://cloudwards.net
http://softwarehow.com
http://macworld.com
http://trusted.de
http://howtogeek.com
http://spiceworkds.com
http://carbonite.com
http://actifio.com
http://asigra.com
http://software.dell.com
http://evault.com
http://falconstor.com
http://intronis.com
http://netapp.com
http://unitrends.com
http://veeam.com
http://veritas.com

  1. Close all those tabs, it's a mess, and restart the browser. You need to keep doing this until it reloads with none of those tabs opening. I find I have to let the tab load before closing it, or it comes back. It wrecks havoc on the console, which makes it pretty impossible to do some of the next steps. Or if you can clear your console after reloading, you're also probably fine.
  2. Go to about:config
  3. Change this pref: browser.newtabpage.activity-stream.asrouter.devtoolsEnabled to true
  4. Change this pref: browser.newtabpage.activity-stream.discoverystream.endpoints to http,https,file
  5. Change this pref: browser.newtabpage.activity-stream.discoverystream.config to {"api_key_pref":"extensions.pocket.oAuthConsumerKey","collapsible":true,"enabled":true,"show_spocs":true,"hardcoded_layout":false,"personalized":true,"layout_endpoint":"https://fdfde809-c40b-4dda-96e1-4df41fab3389.mock.pstmn.io/personalization-v1-layout"}
  6. Set browser.newtabpage.activity-stream.discoverystream.enabled to true.
  7. Enter this into the global browser console (not the console for the single page) Services.obs.notifyObservers(null, "idle-daily");
  8. Restart the browser again.
  9. Open about:newtab#devtools-ds
  10. Scroll to the bottom of that page until you see a spoc in "spoc data" with the id 36296 (there should be only one spoc)
  11. Open it up.
  12. Look for score and item_score in the data, they should be different. score should be higher. I'm getting "item_score": 0.2036, "score": 0.992036
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It's 1 line config change, and has been verified in a previous experiment as to not have a negative impact.
  • String changes made/needed: none
Attachment #9109683 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9109683 [details]
Bug 1593290 - Turn on personalization for DS

Uplift approved for 71 beta 12, thanks.

Attachment #9109683 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have verified that the personalization is successfully turned on for DS using the latest Firefox Beta (71.0b12 Build ID - 20191121155457) installed, on Windows 10 x64, Arch Linux and Mac 10.15.1, using the steps provided in comment 6.

Flags: qe-verify+
Duplicate of this bug: 1571752
You need to log in before you can comment on or make changes to this bug.