Closed Bug 1593347 Opened 1 year ago Closed 1 year ago

Searching in "all address books" doesn't show any results from LDAP

Categories

(MailNews Core :: LDAP Integration, defect)

All
Unspecified
defect
Not set
normal

Tracking

(thunderbird71 fixed, thunderbird72 fixed)

RESOLVED FIXED
Thunderbird 72.0
Tracking Status
thunderbird71 --- fixed
thunderbird72 --- fixed

People

(Reporter: KaiE, Assigned: darktrojan)

Details

(Keywords: regression)

Attachments

(1 file)

This is a regression in TB 72 nightly. It works when using TB 68.

  • Configure the Adams LDAP server as described in bug 1574712 comment #0
  • Keep SSL disabled, to demonstrate that this bug is independent of using SSL.
  • Open address book. Keep the left hand side default selection, which is "all address books".
  • Type a name into the search field, e.g. "Alvarez" and hit enter.
  • Wait a few seconds

The bug is that no results are shown.

As a counter example that still works: On the left hand side, explicitly select the configured Adams LDAP directory and repeat the search. That still works.

(Originally reported in bug 1576364 comment 51, but should be tracked independently, because it's separate from SSL.)

so doesn't exist in 71 beta?

Alice, you're familiar with the LDAP setup, could you please find the regression for us.

Flags: needinfo?(alice0775)

Thank you so much, Alice. I suspected that. Also broken in TB 71.

Hardware: Unspecified → All
Version: unspecified → 71
Flags: needinfo?(geoff)

Strange thing.
I cannot reproduce the issue with New profile on Daily72.0a1(Build ID 20191101101931) Windows10 and TB71.0b1(Build ID 20191024110308) windows10.

However, after once restart TB, It does not work any more.
So, this is something profile is damaged when restart TB.

Sure, the bugs in the range you found are related to converting the address books from MAB formar to SQLite format, see:
https://www.thunderbird.net/en-US/thunderbird/71.0beta/releasenotes/ - third item.

Thanks again!

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(geoff)

This is the most time I've wasted on what turned out to be such a minor fix for a while. As a bonus, in this patch I've re-enabled some tests that I noticed actually pass now that JS is the default provider.

Attachment #9106817 - Flags: review?(jorgk)
Attachment #9106817 - Flags: approval-comm-beta?
Comment on attachment 9106817 [details] [diff] [review]
1593347-ldap-search-results-1.diff

Great, this fixes the "stuck case" I had after migration. Even better that the tests pass now.
Attachment #9106817 - Flags: review?(jorgk)
Attachment #9106817 - Flags: review+
Attachment #9106817 - Flags: approval-comm-beta?
Attachment #9106817 - Flags: approval-comm-beta+

Just to be crystal clear, the tests passed before, they just weren't enabled.

Just to be clear, the tests passed before, they just weren't enabled.

Sure, sorry I didn't express it properly: Even better that (in the course of looking at this you discovered that) the test pass now ;-)

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/ad2a01d029a8
Fix LDAP address book search results. r=jorgk DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 72.0
You need to log in before you can comment on or make changes to this bug.