Closed Bug 159365 Opened 18 years ago Closed 18 years ago

clientLeft and clientTop not supported

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 111207

People

(Reporter: erik, Assigned: jst)

Details

(Keywords: testcase)

Attachments

(1 file)

The two properties clientLeft and clientRight are not implemented.

These values gives the size of the borderLeftWidth + potential scrollbar and the
same for borderTopWidth.

There is a good test case for these in bug #145577 (scrollHeight not supported
on textareas) http://bugzilla.mozilla.org/attachment.cgi?id=91600&action=view

*** This bug has been marked as a duplicate of 111207 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Bug #111207 covers scrollWidth, clientWidth (and Heights) but not clientLeft 
and clientTop.

Maybe if someone changes the description and add that clientLeft/Top is 
covered by that but then it would be easier in the future. (I did check that 
bug before reporting this.)

Reopening since it is a separate issue

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Keywords: mozilla1.2
Keywords: testcase
Any chance to get this into 1.3b ?
Keywords: mozilla1.2mozilla1.3
Bug 111207:s summary updated, this is a dupe.

*** This bug has been marked as a duplicate of 111207 ***
Status: REOPENED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.