Plugins ignore nested embed inside object tags

REOPENED
Assigned to

Status

()

Core
Plug-ins
P3
normal
REOPENED
16 years ago
8 years ago

People

(Reporter: brad, Assigned: Peter Lubczynski)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:NA], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

I was running Mozilla 1.1 Alpha with no problems.  However, when i installed
mozilla 1.1 Beta over it, i started getting this error when i would go to pages
that contain flash.

Here's the error message i get:

"ActiveX Error
Could not create the control {00000000-0000-0000-0000-00000000000}.  Check that
is has been installed on your computer and that this page correctly references it."

Reproducible: Always
Steps to Reproduce:
1. go to www.macromedia.com
2.
3.

Expected Results:  loaded the flash animation

i've had this problem and reported it before.  However, i've tried uninstalling
mozilla, removing the flash plugin, and reinstalling, and i still get this error.

Comment 1

16 years ago
quoting from the previous occurance; bug 152393 comment 1:

"pls [...] tell me ur flash version? Also check and see if npswf32.dll is 
inside the mozilla/plugins folder of ur installation or not. If u don't see it 
there, then type 'about:plugins" inside url bar and see if flash is listed in the 
plugins list...let me know."
Reporter, have you used a clean profile with the new build? Could you try again
with a freshly created one?

Comment 3

16 years ago
Reporter replied in mail:

"i'm running flash 6.0 r40.  And, yup the npswf32.dll is in there.  I've
tried removing it, and reinstalling, to no avail."
(Reporter)

Comment 4

16 years ago
I also tried creating a new profile, but i still got the error when i went to
www.macromedia.com with the new profile.

Comment 5

16 years ago
Please copy/paste your about:plugins here.
(Reporter)

Comment 6

16 years ago
Mozilla Default Plug-in

    File name: npnul32.dll
Default Plug-in

MIME Type Description Suffixes Enabled
* Mozilla Default Plug-in (*.*) * Yes

Shockwave Flash

    File name: NPSWF32.dll
Shockwave Flash 6.0 r40

MIME Type Description Suffixes Enabled
application/x-shockwave-flash Macromedia Flash movie (*.swf) swf Yes
application/futuresplash FutureSplash movie (*.spl) spl Yes

QuickTime Plug-in 5.0.2

    File name: npqtplugin5.dll
The QuickTime Plugin allows you to view a wide variety of multimedia content in
Web pages. For more information, visit the QuickTime Web site.

MIME Type Description Suffixes Enabled
image/x-quicktime QuickTime Image File (*.qtif,*.qti) qtif,qti Yes
image/x-sgi SGI image file (*.sgi,*.rgb) sgi,rgb Yes
image/x-targa TGA image file (*.targa,*.tga) targa,tga Yes
image/tiff TIFF image file (*.tif,*.tiff) tif,tiff Yes
image/x-tiff TIFF image file (*.tif,*.tiff) tif,tiff Yes

QuickTime Plug-in 5.0.2

    File name: npqtplugin4.dll
The QuickTime Plugin allows you to view a wide variety of multimedia content in
Web pages. For more information, visit the QuickTime Web site.

MIME Type Description Suffixes Enabled
audio/x-mpeg MPEG audio file (*.mpeg,*.mpg,*.m1s,*.m1a,*.mp2,*.mpm,*.mpa)
mpeg,mpg,m1s,m1a,mp2,mpm,mpa Yes
image/x-macpaint MacPaint image file (*.pntg,*.pnt,*.mac) pntg,pnt,mac Yes
image/pict PICT image file (*.pict,*.pic,*.pct) pict,pic,pct Yes
image/x-pict PICT image file (*.pict,*.pic,*.pct) pict,pic,pct Yes
image/png PNG image file (*.png) png Yes
image/x-png PNG image file (*.png) png Yes

QuickTime Plug-in 5.0.2

    File name: npqtplugin3.dll
The QuickTime Plugin allows you to view a wide variety of multimedia content in
Web pages. For more information, visit the QuickTime Web site.

MIME Type Description Suffixes Enabled
video/x-mpeg MPEG media file
(*.mpeg,*.mpg,*.m1s,*.m1v,*.m1a,*.m75,*.m15,*.mp2,*.mpm,*.mpv,*.mpa)
mpeg,mpg,m1s,m1v,m1a,m75,m15,mp2,mpm,mpv,mpa Yes
video/mpeg MPEG media file
(*.mpeg,*.mpg,*.m1s,*.m1v,*.m1a,*.m75,*.m15,*.mp2,*.mpm,*.mpv,*.mpa)
mpeg,mpg,m1s,m1v,m1a,m75,m15,mp2,mpm,mpv,mpa Yes
audio/mpeg MPEG audio file (*.mpeg,*.mpg,*.m1s,*.m1a,*.mp2,*.mpm,*.mpa)
mpeg,mpg,m1s,m1a,mp2,mpm,mpa Yes

QuickTime Plug-in 5.0.2

    File name: npqtplugin2.dll
The QuickTime Plugin allows you to view a wide variety of multimedia content in
Web pages. For more information, visit the QuickTime Web site.

MIME Type Description Suffixes Enabled
audio/x-aiff AIFF audio file (*.aiff,*.aif,*.aifc) aiff,aif,aifc Yes
audio/basic uLaw/AU audio file (*.au,*.snd,*.ulw) au,snd,ulw Yes
audio/mid MIDI file (*.mid,*.midi,*.smf,*.kar) mid,midi,smf,kar Yes
audio/x-midi MIDI file (*.mid,*.midi,*.smf,*.kar) mid,midi,smf,kar Yes
audio/midi MIDI file (*.mid,*.midi,*.smf,*.kar) mid,midi,smf,kar Yes
audio/vnd.qcelp QUALCOMM PureVoice audio file (*.qcp) qcp Yes
audio/x-gsm GSM audio file (*.gsm) gsm Yes

QuickTime Plug-in 5.0.2

    File name: npqtplugin.dll
The QuickTime Plugin allows you to view a wide variety of multimedia content in
Web pages. For more information, visit the QuickTime Web site.

MIME Type Description Suffixes Enabled
application/sdp SDP stream descriptor file (*.sdp) sdp Yes
application/x-sdp SDP stream descriptor file (*.sdp) sdp Yes
application/x-rtsp RTSP stream descriptor file (*.rtsp,*.rts) rtsp,rts Yes
video/quicktime QuickTime Movie (*.mov,*.qt) mov,qt Yes
video/flc AutoDesk Animator (FLC) file (*.flc,*.fli) flc,fli Yes
audio/aiff AIFF audio file (*.aiff,*.aif,*.aifc) aiff,aif,aifc Yes

RealJukebox NS Plugin

    File name: nprjplug.dll
RealJukebox Netscape Plugin

MIME Type Description Suffixes Enabled
[*] RealJukebox NS Plugin File (*.*) * Yes

RealOne Player Version Plugin

    File name: nprpverplug.dll
6.0.10.505

MIME Type Description Suffixes Enabled
none RealOne Player Version NS Plugin (*.*) none Yes

Java Plug-in

    File name: NPJPI140_01.dll
Java Plug-in 1.4.0_01 for Netscape Navigator (DLL Helper)

MIME Type Description Suffixes Enabled
application/x-java-applet;jpi-version=1.4.0_01 Java Applet Yes
application/x-java-bean;jpi-version=1.4.0_01 JavaBeans Yes

Java Plug-in

    File name: NPJPI140.dll
Java Plug-in 1.4.0 for Netscape Navigator (DLL Helper)

MIME Type Description Suffixes Enabled
application/x-java-applet;jpi-version=1.4 Java Applet Yes
application/x-java-bean;jpi-version=1.4 JavaBeans Yes

Java Plug-in

    File name: NPOJI610.dll
Java Plug-in 1.4.0 for Netscape Navigator (DLL Helper)

MIME Type Description Suffixes Enabled
application/x-java-vm Java Virtual Machine for Netscape 6.x Yes

Mozilla ActiveX control and plugin support

    File name: npmozax.dll
Mozilla ActiveX control and plugin module

MIME Type Description Suffixes Enabled
application/x-oleobject ActiveX (*.*) * Yes
application/oleobject ActiveX (*.*) * Yes
text/x-activescript ActiveScript(*.axs) *.axs Yes

Adobe Acrobat

    File name: nppdf32.dll
Adobe Acrobat Plug-In Version 5.00 for Netscape

MIME Type Description Suffixes Enabled
application/pdf Acrobat (*.pdf) pdf Yes

RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit)

    File name: nppl3260.dll
RealPlayer(tm) LiveConnect-Enabled Plug-In

MIME Type Description Suffixes Enabled
audio/x-pn-realaudio-plugin RealPlayer(tm) as Plug-in (*.rpm) rpm Yes
(Reporter)

Comment 7

16 years ago
I removed the npmozax.dll from the plugins directory, and now flash works just
fine.  The only problem is that i can't use any activeX controls.  

So it looks like there is some conflict between the version of npmozax.dll and
the npswf32.dll that i had in the plugins directory.

Comment 8

16 years ago
Assigning to Adam since he is the ActiveX plug-in man
Assignee: beppe → adamlock

Comment 9

16 years ago
I have my plugin installed (and flash) and Macromedia site works fine.

One oddity is the most recent version of the plugin specifically handles *.ocx
extensions whereas yours says *.*. It's possible this was fouling up something
in which case, try a later version of the plugin. 

application/x-oleobject ActiveX (*.ocx) *.ocx 
application/oleobject ActiveX (*.ocx) *.ocx 
text/x-activescript ActiveScript(*.axs) *.axs Yes

That error message about being unable to create a
{00000000-0000-0000-0000-00000000000} clsid has also been gone about 6 months
after I fixed some code in the clsid parser.
(Reporter)

Comment 10

16 years ago
Installed the new rev of the plugin.  It fixed the error message
problem...however, it still interferes with the playing of flash.  When
npmozax.dll is in the plugins directory, it won't load any flash.  When i remove
it, it plays just fine.

Comment 11

15 years ago
Hijacking this bug and reassigning.

Basically the issue is that the site has an embed tag inside the object tag.
Normally this is indicative of the site providing support for IE via the OBJECT
tag and Mozilla/Netscape via the EMBED tag.

Currently, the plugin layer sees the classid attribute on the object and goes
off looking for any plugin that can handle "application/x-oleobject" content. It
sees my plugin can handle that type, instantiates it and ignores the nested
embed tag. The code that does that is here:

http://lxr.mozilla.org/seamonkey/source/layout/html/base/src/nsObjectFrame.cpp#1084

In such circumstances, perhaps the plugin code can be a little smarter and test
the content type of the nested embed tag first before falling back on looking
for the application/x-oleobject plugin.
Assignee: adamlock → beppe
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: ActiveX Error when going to page containing flash → Plugins ignore nested embed inside object tags

Comment 12

15 years ago
Probably a dupe of bug 109082?

Comment 13

15 years ago
assigning to peterl to determine if he wants to mark this as a dup.
Assignee: beppe → peterl

Comment 14

15 years ago
milestone changed to mozilla1.3alpha
Target Milestone: --- → mozilla1.3alpha

Comment 15

15 years ago
Created attachment 108094 [details] [diff] [review]
patch v.1

This patch causes the browser to prefer loading nested EMBED tags over OBJECTS
displaying Active-X controls.

Comment 16

15 years ago
1.3 beta
Priority: -- → P3
Whiteboard: [PL2:NA]
Target Milestone: mozilla1.3alpha → mozilla1.3beta

Updated

15 years ago
Status: NEW → ASSIGNED
Keywords: patch

Updated

15 years ago
Blocks: 190852

Comment 17

15 years ago
This never landed, and we're trying to figure out if we should indeed take this
fix.  Removing target milestone for re-targetting.
Target Milestone: mozilla1.3beta → ---

Updated

15 years ago
Target Milestone: --- → Future
(Reporter)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 18

13 years ago
Why was this closed? Nothing has been patched. Was it fixed by another bug?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
QA Contact: shrir → plugins
You need to log in before you can comment on or make changes to this bug.