Closed Bug 1593708 Opened 1 year ago Closed 1 year ago

Persist "inRDMPane" attribute set on the document while in RDM mode

Categories

(DevTools :: Responsive Design Mode, defect, P1)

defect

Tracking

(firefox72 fixed)

RESOLVED FIXED
Firefox 72
Tracking Status
firefox72 --- fixed

People

(Reporter: mtigley, Assigned: mtigley)

References

(Blocks 1 open bug)

Details

(Whiteboard: fission-rdm-mvp)

Attachments

(4 files)

When RDM is open and the user either refreshes or performs a "OnLocationChange" event, attributes on the document (such as the inRDMPane) need to persist.

Steps to Reproduce

  1. Make sure devtools.responsive.browserUI.enabled
  2. Open RDM, and select the iPad from the devices list.
  3. Check screen.height in the DevTools console. You should see a value of 1022 (which is supposed to be 1024, but that's another issue)
  4. Refresh the page and check the value screen.height again.

ER:
The value should still be 1022

AR:
The value is the actual height of the physical device.

Priority: -- → P2
Whiteboard: fission-rdm-mvp

For context, RDM is currently persisting these attributes by overriding the WebProgressListener in its frame content script.

Since we're removing the use of the <iframe mozbrowser> as part of the DevTools fission effort, this also means we will removing its injected content frame script. So we need to find another way to persist the document attributes RDM manipulates when refreshed or navigated. In particular, RDM is using these WebIDL Document extensions to set inRDMPane and screen.orientation:

After discussing this issue with the Fission team, we need to be setting the inRDMPane attribute on the BrowsingContext and not the Document if we need it to persist. I can delve into this more.

Assignee: nobody → mtigley
Status: NEW → ASSIGNED
Priority: P2 → P1
Summary: Persist attributes set on the document while in RDM mode → Persist "inRDMPane" attribute set on the document while in RDM mode
See Also: → 1595800
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8dd6e18ae2af
Part 1: Add inRDMPane property to BrowsingContext and expose it to JS. r=smaug
https://hg.mozilla.org/integration/autoland/rev/157248203e4a
Part 2: Get inRDMPane value from BrowsingContext instead of Document. r=smaug
https://hg.mozilla.org/integration/autoland/rev/33d4fb0808c9
Part 3: Remove inRDMPane attribute from Document. r=bradwerth,smaug
https://hg.mozilla.org/integration/autoland/rev/32913780ebb3
Part 4: Update RDM to set inRDMPane property on the BrowsingContext. r=bradwerth
Regressions: 1597612
You need to log in before you can comment on or make changes to this bug.