Closed Bug 1593819 Opened 3 months ago Closed 3 months ago

Addressbar URL completion works based on "Bookmarks" toogle

Categories

(Firefox :: Address Bar, defect)

70 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1582234

People

(Reporter: thehim, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

I entered the first letter of a frequently visited website, which contains a subdomain (e.g. board.topic.com).

Actual results:

The Addressbar doesn't autocomplete the URL, unless browser.urlbar.suggest.bookmark is set to true. Crucially, this applies to URLs whose domains are not bookmarked.

Expected results:

The Addressbar should expand my entry to the URL of the most visited site, at least if the visiting frequency stands out by a large margin. This behavior should not be dependent on aforementioned "bookmarks" toggle, as the two are functionally independent concepts.

Component: Untriaged → Address Bar
Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1582234

The way my issue doesn't seem to overlap with bug 1582234 is that I don't have the sites in question bookmarked.

There's a bulletin board I visit often that I don't have in my bookmarks (I did a search in "All Bookmarks"), yet its autocompletion depends on whether browser.urlbar.suggest.bookmark is enabled. The theory that it gets blacklisted because it's among the bookmarks doesn't make sense in that case.

I wouldn't be surprised if the two issues are still functionally related though, but there might be another issue in the code path.

May you have another bookmark to the same domain?

No, I should have mentioned that. I made sure isn't not just the subdomain.

By the way, some subdomains do auto-complete with browser.urlbar.suggest.bookmark disabled, so this might be a threshold issue. However, I visit the site in question several times a day.

(In reply to thehim from comment #4)

No, I should have mentioned that. I made sure isn't not just the subdomain.

If you have ANY bookmark url CONTAINING that subdomain, it's affected by bug 1582234
You could try Firefox Beta, Firefox 71 Beta 5 has the fix, if it works there, that's the issue, otherwise we can reopen and do further investigation.

Thanks Marco, understood! I definitely don't have any bookmark containing the domain or subdomain ("isn't not" was supposed to read "it's not"). I have added the issue to my notes and will revisit it once Firefox 71 proper is released. With the bookmarks toggle enabled, I can keep browsing comfortably – I just think it's the wrong toggle.

You need to log in before you can comment on or make changes to this bug.