Closed Bug 159382 Opened 21 years ago Closed 21 years ago

Problems with genreated images

Categories

(Core Graveyard :: File Handling, defect)

Sun
Solaris
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 84106

People

(Reporter: sirtobi, Assigned: law)

Details

I've build an little script which produces an image.
When I call this script from an <form>-tag, it gives back an Content-type:
text/png and then the raw png data.
The image appears in Mozilla and all seems to be fine.
If you try to download the image by right-clicking on it, you only can download
the form from which the generating cgi was called. You have no chance to save
the image !!!
With netscape 4, it works...
we need a testcase !

-> File Handling
Assignee: Matti → law
Component: Browser-General → File Handling
QA Contact: asa → sairuh
1) image/png, not text/png
2) Mozilla might be trying to refetch the image; is the image cachable?

1) image/png, not text/png                                                     
                                                                               
          

Yes, it is from mime-type image/png

2) Mozilla might be trying to refetch the image; is the image cachable?  

When you press reload, it fails. I think it tries to reload the html-page as
image/png.

The problem seems to be, that mozilla loads the image that comes from the cgi,
but it doesn`t change internally to the new type and teh new data.


If you like to test it for a few days, i`ll let the problem-page open for
testing purposes:
http://www.unix-ag.uni-hannover.de/cgi-bin/sirtobi/calbg.cgi

Just press "Generieren" at the bottom of the page...
We forget to pass along the postdata when we save...

*** This bug has been marked as a duplicate of 84106 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.