Crash viewing XBL bindings in DOM inspector [@ js_EmitTree] M11B

RESOLVED DUPLICATE of bug 137191

Status

Other Applications
DOM Inspector
--
critical
RESOLVED DUPLICATE of bug 137191
16 years ago
7 years ago

People

(Reporter: greer, Assigned: Joe Hewitt (gone))

Tracking

({crash, topcrash})

Trunk
x86
Windows 2000
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

16 years ago
Several users have crashed the M11B release by selecting "XBL bindings" from the
dropdown menu with these steps:

     (8595037)	URL: www.google.com
     (8595037)	Comments: Dom Inspector / found an image / view item in new window / xbl
bindings from dropdown

     (8608541)	Comments: I was using the DOM inspector  I had clicked on "Inspect in New
Window"  then selected the following in order:
  1. DOM Model view
  2. Box Model view
  3. When I selected "XBL Bindings" it crashed.

I have tried but not crashed following those steps.

Build ID range: 2002072104 to 2002072204
 
Stack Trace: 

	 js_EmitTree
[c:/builds/seamonkey/mozilla/js/src/jsemit.c  line 1838]
	 EmitElemOp
[c:/builds/seamonkey/mozilla/js/src/jsemit.c  line 1714]
	 js_EmitTree
[c:/builds/seamonkey/mozilla/js/src/jsemit.c  line 3573]
	 js_EmitTree
[c:/builds/seamonkey/mozilla/js/src/jsemit.c  line 3308]
	 js_EmitTree
[c:/builds/seamonkey/mozilla/js/src/jsemit.c  line 3155]
	 js_EmitTree
[c:/builds/seamonkey/mozilla/js/src/jsemit.c  line 3122]
	 js_EmitTree
[c:/builds/seamonkey/mozilla/js/src/jsemit.c  line 1988]
	 js_EmitTree
[c:/builds/seamonkey/mozilla/js/src/jsemit.c  line 3122]
	 js_EmitTree
[c:/builds/seamonkey/mozilla/js/src/jsemit.c  line 2569]
	 js_EmitTree
[c:/builds/seamonkey/mozilla/js/src/jsemit.c  line 3122]
	 js_EmitTree
[c:/builds/seamonkey/mozilla/js/src/jsemit.c  line 1988]
	 Statements
[c:/builds/seamonkey/mozilla/js/src/jsparse.c  line 919]
	 FunctionBody
[c:/builds/seamonkey/mozilla/js/src/jsparse.c  line 558]
	 js_CompileFunctionBody
[c:/builds/seamonkey/mozilla/js/src/jsparse.c  line 603]
	 JS_CompileUCFunctionForPrincipals
[c:/builds/seamonkey/mozilla/js/src/jsapi.c  line 3188]
	 nsJSContext::CompileEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp  line 937]
	 nsXBLPrototypeHandler::ExecuteHandler
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLPrototypeHandler.cpp  line 440]
	 nsXBLFocusHandler::Focus
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLFocusHandler.cpp  line 104]
	 nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp  line
1725]
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3454]
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3435]
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3435]
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3435]
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3435]
	 nsXULElement::HandleChromeEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 4683]
	 GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp  line 759]
	 nsXULDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp  line 2614]
	 nsEventStateManager::PreHandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 505]
	 PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6187]
	 PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6115]
	 nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 2059]
	 nsView::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 306]
	 nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 1916]
	 HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 83]
	 nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1038]
	 nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1055]
	 nsWindow::DispatchFocus
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 5292]
	 nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 3976]
	 nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1304]
	 USER32.DLL + 0x1b60 (0x77e11b60)
	 USER32.DLL + 0x2f29 (0x77e12f29)
	 USER32.DLL + 0x2f4f (0x77e12f4f)
	 ntdll.dll + 0x2032f (0x77fa032f)
	 nsEventStateManager::SendFocusBlur
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 3971]
	 nsEventStateManager::SetContentState
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 3692]
	 nsEventStateManager::TabIntoDocument
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 4866]
	 nsEventStateManager::ShiftFocusInternal
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 2999]
	 nsEventStateManager::ShiftFocusInternal
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 3126]
	 nsEventStateManager::ShiftFocus
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 2861]
	 nsEventStateManager::ShiftFocusInternal
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 3097]
	 nsEventStateManager::ShiftFocus
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 2861]
	 nsEventStateManager::TabIntoDocument
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 4868]
	 nsEventStateManager::ShiftFocusInternal
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 2999]
	 nsEventStateManager::ShiftFocusInternal
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 3126]
	 nsEventStateManager::ShiftFocus
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 2861]
	 nsEventStateManager::ShiftFocusInternal
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 3097]
	 nsEventStateManager::ShiftFocus
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 2861]
	 nsEventStateManager::TabIntoDocument
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 4868]
	 nsEventStateManager::ShiftFocusInternal
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 2999]
	 nsEventStateManager::ShiftFocusInternal
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 3126]
	 nsEventStateManager::ShiftFocus
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 2861]
	 nsEventStateManager::ShiftFocusInternal
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 3097]
	 nsEventStateManager::ShiftFocus
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 2861]
	 nsEventStateManager::TabIntoDocument
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp  line 4868]
 
 	Source File : c:/builds/seamonkey/mozilla/js/src/jsemit.c line : 1838

This URL was mentioned. It doesn't crash for me as a plain URL or in DOM
Inspector...
     (8606488)	URL: http://www.unicum.de/film/lego/filme/brick_fiction.wmv
(Reporter)

Updated

16 years ago
Keywords: crash, topcrash
(Reporter)

Comment 1

16 years ago
cc'ing samir on this DOM Inspector crash.

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 137191 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Other Applications
QA Contact: timeless → dom-inspector
Crash Signature: [@ js_EmitTree]
You need to log in before you can comment on or make changes to this bug.