Closed Bug 1593965 Opened 1 year ago Closed 11 months ago

Reconsider drag&drop indicators for tabs and the bookmarks toolbar

Categories

(Firefox :: Address Bar, task, P2)

task
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 72
Iteration:
72.2 - Nov 4 - 17
Tracking Status
firefox72 --- fixed

People

(Reporter: mak, Assigned: harry)

References

(Blocks 1 open bug)

Details

(Keywords: blocked-ux)

Attachments

(3 files)

Try dragging a link or a bookmark between tabs or on the bookmarks toolbar.
The current indicators, on some platforms, cross the expanded urlbar.
On Windows for example the bookmarks toolbar indicator has a small arrow pointing down at the top, there's no reason for which it may not be an arrow pointing up at the bottom.
Similarly, the tabs indicator is an arrow pointing up below tabs, while it could be an arrow pointing down above tabs (Chrome is panting these arrows out of the window frame, not sure we can).

Something can surely be done to improve visibility of these indicators, apart from just touching z-index (that for the bookmarks toolbar case may not help much).

In the tab drag&drop case, the indicators look quite old and out of place in Photon/modern OS versions with the exception of the macOS indicator. Could UX possibly rework the Windows/Linux indicators to be more vertically-oriented like the macOS indicator? That would solve the issues with the focused megabar.

Having them in SVG would be nice too!

For the sake of putting everything in this one bug, here are the bookmark toolbar indicators. They're also .pngs that might benefit from a more modern look.

Keywords: blocked-ux
Priority: P3 → P2

Can we have someone from UX re-evalate these indicators?

Flags: needinfo?(mverdi)
Attached video drag_regularmode.mp4

I took a screen capture of the behavior on Windows. Linux behaviour is similar. The problem is definitely not as bad as it used to be with the bigger megabar, but it still isn't great.
We've worked around the issue a little by setting the tab d&d arrow to appear above the megabar, but ideally we wouldn't have to do this since it definitely looks like a workaround. It'd be nicer if we had a more vertically-oriented indicator like we have on macOS.
The arrow in the bookmarks toolbar d&d icon is visible, but obscured by the shadow cast by the expanded megabar. For some reason the shadow doesn't appear in the screen capture.

Flags: needinfo?(mverdi) → needinfo?(bbell)
Attached image image.png

We're going to use the macOS-style drop indicator on all platforms. Bryan's prepared an SVG version and a similar-looking toolbar drop indicator as well.

Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Flags: needinfo?(bbell)
Iteration: --- → 72.2 - Nov 4 - 17
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/81b1c17310c2
Use new drag & drop indicators for tabs and the bookmarks toolbar. r=mak,dao
Backout by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/27a1fb60c286
Backed out changeset 81b1c17310c2 for causing failures in browser_startup_images.js CLOSED TREE
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4658f41dadee
Use new drag & drop indicators for tabs and the bookmarks toolbar. r=mak,dao
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
You need to log in before you can comment on or make changes to this bug.