Closed Bug 1594028 Opened 3 months ago Closed 3 months ago

[10.15] Implementation for hardware media keys (bug 1575995) presents "Keystroke Recording" Access Grant Request Dialog

Categories

(Core :: Widget: Cocoa, defect, P1)

67 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1591230

People

(Reporter: spohl, Unassigned)

References

(Regression)

Details

+++ This bug was initially created as a clone of Bug #1563994 +++

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

  1. Enable support for hardware media keys on macOS 10.15

Actual results:

Got prompted to give Firefox "Keystroke Recording" for all applications access.

Expected results:

Should not show dialog.

This is caused by the use of CGEventTapCreate[1], added in bug 1575995.

[1] https://searchfox.org/mozilla-central/rev/3300072e993ae05d50d5c63d815260367eaf9179/dom/media/mediacontrol/MediaHardwareKeysEventSourceMac.mm#85

:alwu, could you take this?

Flags: needinfo?(alwu)

This should be fixed by bug1591230, where we would use MediaPlayer to replace CGEventTap.

Status: NEW → RESOLVED
Closed: 3 months ago
Flags: needinfo?(alwu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1591230
You need to log in before you can comment on or make changes to this bug.