Closed Bug 1594129 Opened 1 year ago Closed 1 year ago

Snippet messages should not be evaluated for trigger actions

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 72
Iteration:
72.2 - Nov 4 - 17
Tracking Status
firefox71 --- fixed
firefox72 --- fixed

People

(Reporter: andreio, Assigned: andreio)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Trigger listeners should use handleMessageRequest (or something similar) to only evaluate related messages.
For example if a openURL trigger is active (not yet seen/blocked) we evaluate all snippet messages for every onLocationChange event.

Assignee: nobody → andrei.br92
Iteration: --- → 72.2 - Nov 4 - 17
Priority: -- → P1
Target Milestone: --- → Firefox 72
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2a0648ebfc02
Snippet messages should not be evaluated for trigger actions r=k88hudson
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9106969 [details]
Bug 1594129 - Snippet messages should not be evaluated for trigger actions

Beta/Release Uplift Approval Request

  • User impact if declined: Should improve performance issues surfaced in bug 1599811 along with bug 1594405 which will also be uplifted. (the second uplift is not a dependency, the two are independent and they mitigate the same issue).
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Patch has been in Nightly for a while, and has tests.
    I didn't request uplift sooner because the bugs that signaled the performance issue were for 72.
  • String changes made/needed:
Attachment #9106969 - Flags: approval-mozilla-beta?

Comment on attachment 9106969 [details]
Bug 1594129 - Snippet messages should not be evaluated for trigger actions

This is too late sorry, we are building RC2 and we are no longer in beta to take non-essential uplifts to our release builds.

Attachment #9106969 - Flags: approval-mozilla-beta? → approval-mozilla-beta-

Comment on attachment 9106969 [details]
Bug 1594129 - Snippet messages should not be evaluated for trigger actions

After talking with Andrei, I am taking this uplift in a new RC as it looks safe, has tests and was on nightly for a while.

Attachment #9106969 - Flags: approval-mozilla-beta- → approval-mozilla-release+
Blocks: 1599811
You need to log in before you can comment on or make changes to this bug.