Closed Bug 1594173 Opened 5 months ago Closed 5 months ago

Add Ad Privacy Info Modal to Top Sites Tile

Categories

(Firefox :: New Tab Page, task, P1)

72 Branch
Desktop
All
task

Tracking

()

VERIFIED FIXED
Firefox 72
Iteration:
72.2 - Nov 4 - 17
Tracking Status
firefox71 + verified
firefox72 --- verified

People

(Reporter: tkanhema, Assigned: gsuntop)

References

Details

(Keywords: github-merged)

Attachments

(2 files)

Add Ad Privacy Info Modal to Top Sites Tile:

  • Impressions
  • Clicks
  • Dismiss
  • CTR to Privacy Page
Summary: Add Privacy Info Modal to Top Sites Tile → Add Ad Privacy Info Modal to Top Sites Tile
Assignee: nobody → gsuntop
Priority: -- → P1
Iteration: --- → 72.2 - Nov 4 - 17
Blocks: 1595901
Status: NEW → RESOLVED
Closed: 5 months ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

I have verified that this issue is no longer reproducible with the latest Firefox Nightly (72.0a1 Build ID - 20191114055112) installed, on Windows 10 x64, Arch Linux and Mac 10.15.1. Now, the "Ad Privacy Info Modal" is displayed for the sponsored "Top Sites".

Status: RESOLVED → VERIFIED

[Tracking Requested - why for this release]:

Gavin, you are not giving reasons why we should track this bug for 71. Please give an explanation for release managers to understand your context, thanks.

Flags: needinfo?(gsuntop)

@pascal I can answer that.

This is a bug we need fixed in order to run a revenue based experiment in 71.

It's not going to live users in 71, and we'll see where we go from there depending on the experiment results. Sooner we can test, the sooner we can turn the feature on if it's a revenue plus.

It's a 1 line change too, so I it's low risk.

Flags: needinfo?(gsuntop)

Comment on attachment 9109676 [details]
Bug 1594173 - Add Ad Privacy Info Modal to Top Sites Tile

Beta/Release Uplift Approval Request

  • User impact if declined: Impact to revenue based experiment
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Update browser.newtabpage.activity-stream.discoverystream.endpoints with https://,http://
  1. Update browser.newtabpage.activity-stream.discoverystream.config with {"api_key_pref":"extensions.pocket.oAuthConsumerKey","collapsible":true,"enabled":true,"show_spocs":true,"hardcoded_layout":false,"personalized":false,"layout_endpoint":"https://5ad1b408-b40a-4a49-b6ec-27473d192df0.mock.pstmn.io"}
  2. Click the three dot context menu on Netflix top site. You should see "Our sponsors & your privacy". Clicking it should show privacy modal.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): 1 line, verified on nightly.
  • String changes made/needed: none
Attachment #9109676 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9109676 [details]
Bug 1594173 - Add Ad Privacy Info Modal to Top Sites Tile

P1, covered by tests and has steps for manual QA, uplift approved for 71 beta 12, thanks.

Attachment #9109676 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have verified that the "Ad Privacy Info Modal" is displayed for the sponsored "Top Sites", using the latest Firefox Beta (71.0b12 Build ID - 20191121155457) installed on Windows 10 x64, Arch Linux, and Mac 10.15.1.

Flags: qe-verify+
Duplicate of this bug: 1589645
You need to log in before you can comment on or make changes to this bug.