chatzilla won't connect to same server on different ports

VERIFIED DUPLICATE of bug 156928

Status

Other Applications
ChatZilla
VERIFIED DUPLICATE of bug 156928
16 years ago
13 years ago

People

(Reporter: Jacob Kjome, Assigned: Robert Ginda)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Using Chatzilla client from Mozilla build 2002072504 on Win2k (sp2sr1)

I use Port forwarding through SSH...for various reasons... to connect to the IRC
from Chatzilla.  The thing is, different ports represent different servers even
though the server that Chatzilla thinks it is connecting to is "localhost".  

For instance, to connect to "irc.mozilla.org:6667", I enter: 
"/server localhost:5001"

To connect to my preferred efnet server "irc.easynews.com:6667", I enter:
"/server localhost:5002"

My port forwarder at home turns requests for these ports into requests for the
actual server locations.

The problem is that once I am connected to "localhost" at any port, I cannot
connect to locahost as another "/server" entry.  Chatzilla reports:
[ERROR]Already connected to localhost

I can slightly work around this by doing "/server 127.0.0.1:5002".  Notice that
it is going to the same server.  The name is just different.

So, I think Chatzilla should take into consideration the whole address including
the port number instead of treating the same server address with different ports
as the same thing.

Any fix for this bug would allow me to connect to all the following servers in
the same Chatzilla session:

/server localhost:5001
/server localhost:5002
/server localhost:5003

The only time I'd get an error is if, for instance, after connecting to the
above servers I typed "/server localhost:5001".

Jake

Comment 1

16 years ago
Sorry, the other bug hadn't been confirmed, which would have made it more
difficult to find.

*** This bug has been marked as a duplicate of 156928 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.