Closed Bug 1594381 Opened 1 year ago Closed 1 year ago

Crash in [@ RetainedDisplayListBuilder::MergeDisplayLists]

Categories

(Core :: Web Painting, defect)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 blocking fixed

People

(Reporter: pascalc, Unassigned)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-85d7fdbf-390e-4f95-827c-6f5120191106.

Top 10 frames of crashing thread:

0 XUL RetainedDisplayListBuilder::MergeDisplayLists layout/painting/RetainedDisplayListBuilder.cpp:839
1 XUL MergeState::MergeChildLists layout/painting/RetainedDisplayListBuilder.cpp:516
2 XUL RetainedDisplayListBuilder::MergeDisplayLists layout/painting/RetainedDisplayListBuilder.cpp:839
3 XUL RetainedDisplayListBuilder::AttemptPartialUpdate layout/painting/RetainedDisplayListBuilder.cpp:1523
4 XUL nsLayoutUtils::PaintFrame layout/base/nsLayoutUtils.cpp:3905
5 XUL mozilla::PresShell::Paint layout/base/PresShell.cpp:6093
6 XUL nsViewManager::ProcessPendingUpdatesPaint view/nsViewManager.cpp:461
7 XUL nsViewManager::ProcessPendingUpdatesForView view/nsViewManager.cpp:396
8 XUL nsViewManager::ProcessPendingUpdates view/nsViewManager.cpp:1019
9 XUL nsRefreshDriver::Tick layout/base/nsRefreshDriver.cpp:2148

The last nightly (20191106095742) is crashing with this signature, I stopped automatic updates on Nightly because of that.
Changelog of this build:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4d585c7edc7683e4b35eca6b18c9a646a1b8a78d&tochange=d73cfe3a04e90b5dff64f6d4e3c3a9183aec4ec5

Alexis, could you look if the patches in https://bugzilla.mozilla.org/show_bug.cgi?id=1554499 are the cause of these crashes please? Thanks

Flags: needinfo?(a.beingessner)

I am looking into this.

Flags: needinfo?(a.beingessner)
Status: NEW → RESOLVED
Closed: 1 year ago
Regressed by: 1554499
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Please specify a root cause for this bug. See :tmaity for more information.

Root Cause: --- → ?
Root Cause: ? → Coding: Internal API Issue
You need to log in before you can comment on or make changes to this bug.