Closed Bug 1594407 Opened 1 year ago Closed 1 year ago

5.32 - 21.19% perf_reftest_singletons (linux64-shippable|-qr, macosx1014-64-shippable, windows10-64-shippable-qr) regression on push 749fec0af5162a9c51281cac24dde45c22f27ed5 (Mon November 4 2019)

Categories

(Firefox Build System :: Toolchains, defect)

defect
Not set
normal

Tracking

(firefox-esr68 unaffected, firefox70 unaffected, firefox71 unaffected, firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- fixed

People

(Reporter: alexandrui, Assigned: dmajor)

References

(Blocks 1 open bug, Regression)

Details

(4 keywords)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=749fec0af5162a9c51281cac24dde45c22f27ed5

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

21% perf_reftest_singletons external-string-pass.html macosx1014-64-shippable opt e10s stylo 955.80 -> 1,158.37
9% perf_reftest_singletons id-getter-2.html linux64-shippable-qr opt e10s stylo 728.47 -> 793.06
9% perf_reftest_singletons id-getter-2.html linux64-shippable opt e10s stylo 701.03 -> 762.98
7% perf_reftest_singletons id-getter-4.html windows10-64-shippable-qr opt e10s stylo 480.74 -> 514.32
7% perf_reftest_singletons id-getter-6.html windows10-64-shippable-qr opt e10s stylo 480.61 -> 513.16
7% perf_reftest_singletons id-getter-7.html windows10-64-shippable-qr opt e10s stylo 480.86 -> 512.89
5% perf_reftest_singletons external-string-pass.html linux64-shippable-qr opt e10s stylo 942.82 -> 994.50
5% perf_reftest_singletons external-string-pass.html windows10-64-shippable-qr opt e10s stylo 1,009.98 -> 1,063.67

Improvements:

8% tp5n main_startup_fileio windows7-32-shippable opt e10s stylo 108,317,107.33 -> 99,830,629.50

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=23707

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/TestEngineering/Performance/Talos

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/TestEngineering/Performance/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/TestEngineering/Performance/Talos/RegressionBugsHandling

Flags: needinfo?(dmajor)
Component: Performance → Toolchains
Product: Testing → Firefox Build System
Version: Version 3 → unspecified

I am actively investigating this, but my ability to make progress is limited by the constant talos backlog on try, especially since try jobs are prioritized below autoland.

Assignee: nobody → dmajor
Flags: needinfo?(dmajor)

Checking in to note that I'm continuing to investigate.

Depends on: 1596172
Depends on: 1596198

I believe this should be addressed now by the two bugs linked above.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.