If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

processmail.pl does not process ARGS correctly.

RESOLVED DUPLICATE of bug 136156

Status

()

Bugzilla
Email Notifications
RESOLVED DUPLICATE of bug 136156
15 years ago
5 years ago

People

(Reporter: David Chubb, Assigned: preed)

Tracking

2.14.2
x86
Windows 2000

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
We have a problem with getting Process mail to work correctly from within 
Apache. I can run it fine from the command line.

When the system call from post_bug.cgi calls this line:

system("perl", "processmail.pl", $id, $::COOKIE{'Bugzilla_login'});

(Note: It would give us errors until we changed "perl processmail.pl" 
to "perl", "processmail.pl")

Processmail.pl does not process the e-mail. 

If I submit the same call via a test script (show below...the ID is a freshly 
submitted bug) it works fine.

Test script:
$id = 18;
$id_email = "dchubb@virpack.com";

system("perl", "processmail.pl", $id, $id_email);

run as a perl script from command line. Apache's logs don't show anything and 
it acts as if it executes fine but no e-mails get sent (I can monitor the SMTP 
server's access logs).

I have modified the processmail.pl file with the changes to use NT Sendmail 
(show below).

    if ($enableSendMail == 1) {
    #open(SENDMAIL, "|/usr/lib/sendmail $sendmailparam -t") ||
    #  die "Can't open sendmail";
    #print SENDMAIL trim($msg) . "\n";
    #close SENDMAIL;
	
	#Sendmail change for NT sendmail.
	my $mail=new NTsendmail; 
	my $from="bugzilla\@virpack.com"; 
	my $to=$person; 
	my $subject = $isnew ? 'New Bug: $id ' : 'Bug Changed: $id ';
	$mail->send($from,$to,$subject,$msg); 
    }
(Reporter)

Comment 1

15 years ago
Created attachment 92792 [details]
Current version of processmail.
(Assignee)

Comment 2

15 years ago
This looks like a dup of bug 136156.

The "correct" solution is being worked on: bug 124174.

Marking as dup; reopen with explanation if you disagree.

*** This bug has been marked as a duplicate of 136156 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.