Closed Bug 1594560 Opened 2 years ago Closed 2 years ago

Crash in [@ nsReadConfig::Observe]

Categories

(Core :: XPCOM, defect)

Desktop
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1594404
Tracking Status
firefox71 --- unaffected
firefox72 --- fixed

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-4d49c037-8856-49a8-ae5b-be51c0191106.

Small volume macOS crash which started in 20191106095742: https://bit.ly/36DlASs. 10 crashes so far. There is some autoconfig in the stack. Adding ni on :jandem in case this is related to Bug 1579367 which is in the changeset below.

Possible regression range based on build id: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4d585c7edc7683e4b35eca6b18c9a646a1b8a78d&tochange=d9daf28a5559712a8db772aa8388f444a93f4063

Top 9 frames of crashing thread:

0 XUL nsReadConfig::Observe extensions/pref/autoconfig/src/nsReadConfig.cpp:91
1 XUL nsObserverList::NotifyObservers xpcom/ds/nsObserverList.cpp:66
2 XUL nsObserverService::NotifyObservers xpcom/ds/nsObserverService.cpp:291
3 XUL mozilla::Preferences::InitializeUserPrefs modules/libpref/Preferences.cpp:3672
4 XUL XREMain::XRE_main toolkit/xre/nsAppRunner.cpp:4740
5 XUL mozilla::BootstrapImpl::XRE_main toolkit/xre/Bootstrap.cpp:45
6 firefox main browser/app/nsBrowserApp.cpp:300
7 libdyld.dylib libdyld.dylib@0x11404 
8 libdyld.dylib libdyld.dylib@0x11404 

Flags: needinfo?(jdemooij)

Thanks for filing. I think this is a dupe of bug 1594404, which was fixed by backout.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jdemooij)
Resolution: --- → DUPLICATE
Duplicate of bug: 1594404
You need to log in before you can comment on or make changes to this bug.