Closed Bug 1594743 Opened 1 year ago Closed 1 year ago

When performing keyboard and label checks at the same time, accessible name is reported as null when used inside a label check.

Categories

(DevTools :: Accessibility Tools, defect)

defect
Not set
normal

Tracking

(firefox71 fixed, firefox72 fixed)

RESOLVED FIXED
Firefox 72
Tracking Status
firefox71 --- fixed
firefox72 --- fixed

People

(Reporter: yzen, Assigned: yzen)

Details

Attachments

(1 file)

This is a really weird bug that happens when we have keyboard and text label and names checks happen at the same time. Whenever we query accessible's name, it is reported as null, even though it should something non-empty. This seems to happen somehow because of the call to InspectorUtils.addPseudoClassLock... If I disable that line where we are checking if an element has pseudo focus styling, the name is reported correctly...

Doesn't seem like there are any accessible events fired when applying the lock..

Just FYI these are the functions that area called when the lock is applied, perhaps something triggers some sort of change in platform a11y:

InspectorUtils::AddPseudoClassLock
-> Element::LockStyleStates
---> Element::NotifyStyleStateChange
-----> PresShell::ContentStateChanged
-------> RestyleManager::ContentStateChanged

Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e727898953ed
ensure that the keyboard audit does not interfere with other audit types. r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72

Comment on attachment 9107544 [details]
Bug 1594743 - ensure that the keyboard audit does not interfere with other audit types. r=nchevobbe

Beta/Release Uplift Approval Request

  • User impact if declined: Keyboard audit currently interferes with other audits and needs to be done separately. Users of the a11y panel will see false positives that happen because of that.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This patch simply ensures that the a11y audit for keyboard happens before all other ones instead of at the same time.
  • String changes made/needed:
Attachment #9107544 - Flags: approval-mozilla-beta?

Comment on attachment 9107544 [details]
Bug 1594743 - ensure that the keyboard audit does not interfere with other audit types. r=nchevobbe

Uplift approved for 71 beta 11, thanks.

Attachment #9107544 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.