mime type image/x-xbitmap not included?

CLOSED WORKSFORME

Status

()

--
enhancement
CLOSED WORKSFORME
16 years ago
16 years ago

People

(Reporter: rgflink, Assigned: pavlov)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

I noticed that the mime type, which I happen to use in my website's counter perl
script, of image/x-xbitmap, is not supported by mozilla.

I have been using this counter script for years.

The question/bug/inquiry is why was this long-time supported image type (on NN
and IE) not included in mozilla?

Reproducible: Always
Steps to Reproduce:
1.Load http://wwwcsif.cs.ucdavis.edu/~flink/count.xbm in mozilla
2.Load http://wwwcsif.cs.ucdavis.edu/~flink/count.xbm in IE or NN to compare
3.Compare difference (shows the picture in NN and IE, tries to download in mozilla

Actual Results:  Mozilla says "You have chosen to download a file of type:
image/x-xbitmap from
http://wwwcsif.cs.ucdavis.edu/~flink
What should Mozilla do with this file?


Expected Results:  It should have shown the number 25 in a 16x16 pixel black
text on white background image.

I posted an example from my counter at
http://wwwcsif.cs.ucdavis.edu/~flink/count.xbm so others may see the file. If
you download it, its contents are:
#define count_width 16
#define count_height 16
static char count_bits[] = {
0x00,0x00,0x00,0x00,0x00,0x00,0x3c,
0x7e,0x66,0x06,0x60,0x06,0x60,0x06,
0x30,0x3e,0x18,0x60,0x0c,0x60,0x06,
0x60,0x06,0x66,0x7e,0x3c,0x00,0x00,
0x00,0x00,0x00,0x00};
-------------------------------------- which defines the bitmap for the number
25 (note the digits are reversed, that is normal):
0000000000000000
0000000000000000
0000000000000000
0011110001111110
0110011000000110
0110000000000110
0110000000000110
0011000000111110
0001100001100000
0000110001100000
0000011001100000
0000011001100110
0111111000111100
0000000000000000
0000000000000000
0000000000000000
------------------------- this is all just describing image/x-xbitmap

Comment 1

16 years ago
Worksforme in build 2002072203 (1.1b) - I'm seeing counter 25 ...

It was added in 1.1a : see bug 8031
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 2

16 years ago
Verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

16 years ago
--I downloaded 1.1b, sure enough, it was enabled... maybe someone should add the
keyword image/x-xbitmap to bug 8031 so this doesnt happen again... for being the
but that it is, the only way to get it is searching for xbm (which, from my
original problem, was not at all what I was dealing with - a image/x-xbitmap
stream from a .pl) 
Someone can feel free to mark this as a duplicate of 8031 (and consequently
54432, 62311, 70646)
Status: VERIFIED → CLOSED
You need to log in before you can comment on or make changes to this bug.