Closed Bug 1595316 Opened 1 year ago Closed 1 year ago

URL suggestions bar is significantly lighter than Dark theme when in Default theme (Windows 10 is in dark mode)

Categories

(Firefox :: Theme, defect)

72 Branch
Desktop
Windows
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1540515
Tracking Status
firefox-esr68 --- wontfix
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- wontfix

People

(Reporter: billdillensrevenge, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Darktheme.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

On Windows 10 v1903, Windows is set to dark mode. When Firefox is in its Default theme, the URL suggestions bar is significantly lighter than it is in Firefox's Dark theme. I don't know if this was intentional or not but I think this should be changed, there should be no difference. See attached screenshots

Attached image Defaulttheme.png

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Theme

Dao, is this expected? It sounds like a regression...

Flags: needinfo?(dao+bmo)

I have managed to regress it with mozregression and came up with this result:
"2019-11-12T11:27:28: INFO : platform_version: 68.0a1
2019-11-12T11:28:12: DEBUG : Starting merge handling...
2019-11-12T11:28:12: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=824a86797c8ecbb1a6395ac9fd76ad6abe724766&full=1
2019-11-12T11:28:13: DEBUG : Found commit message:
Bug 1525762: Part 1j - Work around XPI omni.jar packaging issues. r=bustage CLOSED TREE

We have some convoluted packaging logic to automatically package any directory
with a manifest.json file as an XPI. Unfortunately, that logic also applies to
extensions that are supposed to be part of omni.ja.

It would be nice to have a cleaner way to filter out any resources which we've
already flagged to be part of omni.ja, but this patch takes the simpler
approach of just including anything that's in a modules/ directory, which is
whitelisted for omni.ja elsewhere.

2019-11-12T11:28:13: DEBUG : Did not find a branch, checking all integration branches
2019-11-12T11:28:13: INFO : The bisection is done.
2019-11-12T11:28:13: INFO : Stopped"

I have to mention that I had to skip the last 2 builds that mozregression threw at me because it would not have the Windows dark theme applied at all, so I could not determine whether they're good or a bad builds. In any case, I believe the result is correct.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Windows
Regressed by: 1525762
Hardware: Unspecified → Desktop
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(dao+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1540515
You need to log in before you can comment on or make changes to this bug.