Open Bug 1595393 Opened 3 months ago Updated 1 day ago

Intermittent browser/base/content/test/general/browser_bug763468_perwindowpb.js | A promise chain failed to handle a rejection: (Unable to convert rejection reason to string.) - stack: listener@resource://testing-common/BrowserTestUtils.jsm:468:13

Categories

(Firefox :: General, defect, P5)

defect

Tracking

()

REOPENED

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Regression)

Details

(Keywords: intermittent-failure)

Filed by: nerli [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=275536872&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/ARG_DGPMTGetrLeKgVbDqA/runs/0/artifacts/public/logs/live_backing.log


[task 2019-11-10T10:34:13.665Z] 10:34:13 INFO - TEST-START | browser/base/content/test/general/browser_bug763468_perwindowpb.js
[task 2019-11-10T10:34:15.379Z] 10:34:15 INFO - GECKO(3066) | JavaScript error: , line 0: uncaught exception: undefined
[task 2019-11-10T10:34:15.408Z] 10:34:15 INFO - TEST-INFO | started process screentopng
[task 2019-11-10T10:34:15.808Z] 10:34:15 INFO - TEST-INFO | screentopng: exit 0
[task 2019-11-10T10:34:15.809Z] 10:34:15 INFO - Buffered messages logged at 10:34:13
[task 2019-11-10T10:34:15.809Z] 10:34:15 INFO - Entering test bound testPBNewTab
[task 2019-11-10T10:34:15.810Z] 10:34:15 INFO - Buffered messages logged at 10:34:14
[task 2019-11-10T10:34:15.810Z] 10:34:15 INFO - TEST-PASS | browser/base/content/test/general/browser_bug763468_perwindowpb.js | URL of NewTab should be about:newtab in normal mode -
[task 2019-11-10T10:34:15.810Z] 10:34:15 INFO - TEST-PASS | browser/base/content/test/general/browser_bug763468_perwindowpb.js | URL of NewTab should be about:privatebrowsing in per window private browsing mode -
[task 2019-11-10T10:34:15.811Z] 10:34:15 INFO - Buffered messages logged at 10:34:15
[task 2019-11-10T10:34:15.811Z] 10:34:15 INFO - TEST-PASS | browser/base/content/test/general/browser_bug763468_perwindowpb.js | URL of NewTab should be about:newtab in normal mode -
[task 2019-11-10T10:34:15.811Z] 10:34:15 INFO - Leaving test bound testPBNewTab
[task 2019-11-10T10:34:15.812Z] 10:34:15 INFO - Console message: [JavaScript Error: "uncaught exception: undefined"]
[task 2019-11-10T10:34:15.812Z] 10:34:15 INFO - Buffered messages finished
[task 2019-11-10T10:34:15.812Z] 10:34:15 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug763468_perwindowpb.js | A promise chain failed to handle a rejection: (Unable to convert rejection reason to string.) - stack: listener@resource://testing-common/BrowserTestUtils.jsm:468:13
[task 2019-11-10T10:34:15.812Z] 10:34:15 INFO - EventListener.handleEventbrowserLoaded/<@resource://testing-common/BrowserTestUtils.jsm:480:27
[task 2019-11-10T10:34:15.812Z] 10:34:15 INFO - browserLoaded@resource://testing-common/BrowserTestUtils.jsm:439:12
[task 2019-11-10T10:34:15.813Z] 10:34:15 INFO - openNewTab@chrome://mochitests/content/browser/browser/base/content/test/general/browser_bug763468_perwindowpb.js:50:38
[task 2019-11-10T10:34:15.813Z] 10:34:15 INFO - doTest@chrome://mochitests/content/browser/browser/base/content/test/general/browser_bug763468_perwindowpb.js:31:11
[task 2019-11-10T10:34:15.813Z] 10:34:15 INFO - async
testPBNewTab@chrome://mochitests/content/browser/browser/base/content/test/general/browser_bug763468_perwindowpb.js:41:9
[task 2019-11-10T10:34:15.813Z] 10:34:15 INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1069:34
[task 2019-11-10T10:34:15.814Z] 10:34:15 INFO - Tester_execTest@chrome://mochikit/content/browser-test.js:1104:11
[task 2019-11-10T10:34:15.814Z] 10:34:15 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:932:14
[task 2019-11-10T10:34:15.814Z] 10:34:15 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:805:67
[task 2019-11-10T10:34:15.814Z] 10:34:15 INFO - Rejection date: Sun Nov 10 2019 10:34:15 GMT+0000 (Coordinated Universal Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 265
[task 2019-11-10T10:34:15.814Z] 10:34:15 INFO - Stack trace:
[task 2019-11-10T10:34:15.815Z] 10:34:15 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:265
[task 2019-11-10T10:34:15.815Z] 10:34:15 INFO - chrome://mochikit/content/browser-test.js:nextTest:631
[task 2019-11-10T10:34:15.815Z] 10:34:15 INFO - chrome://mochikit/content/browser-test.js:testScope/test_finish/<:1451
[task 2019-11-10T10:34:15.815Z] 10:34:15 INFO - chrome://mochikit/content/browser-test.js:run:1366
[task 2019-11-10T10:34:15.816Z] 10:34:15 INFO - GECKO(3066) | MEMORY STAT | vsize 3331MB | residentFast 530MB | heapAllocated 264MB

This seems to be a regression from https://bugzilla.mozilla.org/show_bug.cgi?id=1492582
Brendan, could you please take a look at this?

Flags: needinfo?(bdahl)
Regressed by: 1492582

Same as the other bug...I've only seen this one failure and cannot reproduce locally. I'll keep an eye on it, but clearing the needinfo.

Flags: needinfo?(bdahl)
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → INCOMPLETE
Status: REOPENED → RESOLVED
Closed: 2 months ago13 days ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
You need to log in before you can comment on or make changes to this bug.