Closed Bug 1595596 Opened 9 months ago Closed 4 months ago

Crash in [@ LZ4F_decodeHeader]

Categories

(Toolkit :: Startup and Profile System, defect, P2)

71 Branch
All
Windows
defect

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- wontfix
firefox72 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- fixed

People

(Reporter: philipp, Assigned: dthayer)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(2 files)

This bug is for crash report bp-d9fab019-262c-41e6-8079-056ae0191111.

Top 10 frames of crashing thread:

0 mozglue.dll static unsigned int LZ4F_decodeHeader mfbt/lz4/lz4frame.c:1119
1 mozglue.dll LZ4F_decompress mfbt/lz4/lz4frame.c:1395
2 mozglue.dll mozilla::Compression::LZ4FrameDecompressionContext::Decompress mfbt/Compression.cpp:181
3 xul.dll mozilla::scache::StartupCache::GetBuffer startupcache/StartupCache.cpp:387
4 xul.dll ReadCachedScript js/xpconnect/loader/mozJSLoaderUtils.cpp:25
5 xul.dll nsresult mozJSComponentLoader::ObjectForLocation js/xpconnect/loader/mozJSComponentLoader.cpp:820
6 xul.dll mozJSComponentLoader::Import js/xpconnect/loader/mozJSComponentLoader.cpp:1340
7 xul.dll static bool mozilla::dom::module_getter::ModuleGetter dom/base/ChromeUtils.cpp:513
8 xul.dll js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:550
9 xul.dll js::CallGetter js/src/vm/Interpreter.cpp:760

this is a low volume crash (so far only in windows) apparently related to the new way that startup cache is working after bug 1550108.

the crash reason field for these reports indicate that some external factors are playing a role in this:
EXCEPTION_IN_PAGE_ERROR_READ / STATUS_IO_DEVICE_ERROR
EXCEPTION_IN_PAGE_ERROR_READ / STATUS_DEVICE_DATA_ERROR
EXCEPTION_IN_PAGE_ERROR_READ / STATUS_DEVICE_HARDWARE_ERROR

Crash Signature: [@ LZ4F_decodeHeader] → [@ LZ4F_decodeHeader] [@ LZ4_decompress_safe]

Doug, could you have a look at this regression caused by 1550108? Thanks

Flags: needinfo?(dothayer)

Think I have a fix for this. However, I'm curious if similar crashes have been showing up for a while under the ScriptPreloader. My understanding of what's causing this makes me think that they ought to.

Assignee: nobody → dothayer
Status: NEW → ASSIGNED
Flags: needinfo?(dothayer)

This is not, AFAICT, causing crashes - it is just an oversight noticed while
investigating the crash in the bug.

Please double check that I am using this correctly. I believe we are
seeing the crash in the linked bug because we are not handling hardware
faults when reading from the memory mapped file. This patch just wraps
all accesses in the MMAP_FAULT_HANDLER_ macros.

Depends on D53042

We have shipped our last beta for 71, since there is a patch in the bug, I am setting the status as fix-optional for 71 in case there is a safe uplift possible in a potential dot release as a ride-along.

The priority flag is not set for this bug.
:mossop, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dtownsend)
Flags: needinfo?(dtownsend)
Priority: -- → P2

There are some r+ patches which didn't land and no activity in this bug for 2 weeks.
:dthayer, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(dothayer)
Pushed by dothayer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1e21eefd5fce
Always wait on Prefetch thread before touching mCacheData r=froydnj
https://hg.mozilla.org/integration/autoland/rev/34c018c96749
Use MMAP_FAULT_HANDLER in StartupCache r=aklotz
Attachment #9108753 - Attachment description: Bug 1595596 - Always wait on Prefetch thread before touching mCacheData r?froydnj → Bug 1595596 - Always wait on Prefetch thread before touching mCacheData
Attachment #9108754 - Attachment description: Bug 1595596 - Use MMAP_FAULT_HANDLER in StartupCache r?aklotz → Bug 1595596 - Use MMAP_FAULT_HANDLER in StartupCache
Pushed by dothayer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/941df4ca0eb8
Always wait on Prefetch thread before touching mCacheData r=froydnj
https://hg.mozilla.org/integration/autoland/rev/322f2ff6b80a
Use MMAP_FAULT_HANDLER in StartupCache r=aklotz
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77

Crash volume looks pretty low for this, so let's just let it ride the 77 train to release. Free free to nominate for Beta approval if you feel strongly otherwise, however.

Flags: needinfo?(dothayer)
You need to log in before you can comment on or make changes to this bug.