Last Comment Bug 159572 - Opening and closing tabs increases memory usage
: Opening and closing tabs increases memory usage
Status: RESOLVED DUPLICATE of bug 131456
:
Product: SeaMonkey
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: x86 Windows XP
: -- critical (vote)
: ---
Assigned To: jag (Peter Annema)
: Patty Mac
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-26 10:21 PDT by Ray Trent
Modified: 2008-07-31 01:19 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Ray Trent 2002-07-26 10:21:08 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

There appears to be a memory leak when opening or closing tabs. If I load the
bug report page: http://mozilla.org/quality/help/bugzilla-helper.html repeatedly
in new tabs, and then close those tabs, my WinXP Task Manager shows the memory
footprint of mozilla increasing rapidly.

As with all potention memory leaks, it's hard to tell from just this data
exactly what's going on. It's possible that it has nothing to do with tabs
specifically (see bug #81446 for a possible cause). 

In particular, it's possible that Windows' Task Manager is smoking crack.
However, I have noticed that if I leave Mozilla up for a long time, I start to
get noticable performance degradation on my machine about the time when my
Commit Charge exceeds my amount of physical memory (256MB). So I tend to think
that if it's a hallucination, it's a pervasive one.



Reproducible: Always
Steps to Reproduce:
1. Load mozilla.org in a window with Task Manager up. Observe the memory usage.
2. Ctrl+Shift+Click on "Report a bug" 10 times to create 10 tabs in the
background (make sure Ctrl+Click is set to open a tab).
3. Close the resulting 10 tabs and observe the memory usage.

Actual Results:  Here are some numbers. In each pair XXX/YYY, this is the memory
footprint reported by the Task Manager for mozilla.exe during a test run. A test
run consists of loading the above page 10 times in 10 tabs (after which the mem
usage is XXX) and then closing those 10 tabs (after which the memory usage is YYY).

Starting memory usage before test: 20864KB. My mozilla memory cache parameter is
set to 5000K, which is much smaller than the total increase in footprint, though
that shouldn't matter for this test.

28412/27720, 28856/28184, 29536/29356, 30496/29496, 30196/30172, 30768/29708,
30668/29756, 30896/29996, 30780/29932, 31156/31028, 31224/31092.

It's interesting that the increases aren't completely monotonic, but I can think
of many reasons why that might be.

Expected Results:  I would expect that the memory footprint of mozilla would
increase when the 10 tabs were open, but drop back down to roughly the previous
memory usage when the tabs are closed.
Comment 1 Wesha 2002-07-26 12:21:44 PDT
   Reporter, your build is too old a build to report bugs against now.
The problem you are reporting may well have been fixed already.

   Could you please download a recent nightly build from
   ftp://ftp.mozilla.org/pub/mozilla/nightly/
   and then let us know if you still see this problem?

   Thanks.
Comment 2 Ray Trent 2002-07-26 13:46:52 PDT
My apologies for improper protocol. 

I've downloaded and tried 2002072608 and the same thing happens.

I've noticed the various memory leak tools, etc., in the debug and QA menus of
the nightly build, but I'm not sure where to find documentation on them. If it
would be helpful, I'm happy to run any tests desired, just let me know.
Comment 3 Ray Trent 2002-09-18 17:00:52 PDT
Don't know if this is related or a different bug, but I've also noticed that if
I open a huge number of tabs (say 50+?) and play around in a lot of them
(navigate back and forward, submit forms, etc., particular in bulletin board
messages) that sometimes the browser starts to freeze up eventually, not
allowing my to navigate back, taking forever to load pages, etc.
Comment 4 Matt Wetherill 2003-02-26 07:03:32 PST
I see this same bug when using W2K SP3.
When using tabs extensively (say up to 8 concurrently), navigating around tabs
and closing / opening new tabs frequently, W2K reports low virtual memory and
resizes the paging file.  Eventually the system freezes and requires reboot.
Closing tabs does not release memory, only closing and restarting the browser
fixes the issue (if caught before system freeze).
Comment 5 louie_medina 2003-04-10 05:08:23 PDT
Keeping those tabs open, too, will eventually lead up to 100% CPU usage and slow
down the system.
Comment 6 Kai Lahmann (is there, where MNG is) 2003-06-02 19:02:21 PDT
Reporter: Can you reproduce this bug with a recent build of Mozilla (for
example, 1.4 RC1)? If so, then please comment again with details. If not, then
please resolve this bug as WORKSFORME. Thanks.
Comment 7 Michael Froomkin 2003-06-09 08:43:17 PDT
I have this problem -- or something very similar -- with 1.4 RC1 on win 98SE,
fully patched.  Open and close many tabs, then even with three or four open if
one is a complex page, the system slows dramatically, and fonts/graphics start
to go wild.  Closing all apps solves the problem.  I did not have this problem
with 1.3, although I did have it with 1.4 alpha so I think it's something new to
1.4, but not new to RC1.
<p>
Note that this bug is ID'd as win XP, but I suspect it affects all win versions.
 Also, is this related to Bugzilla <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=131456">Bug 131456</a>?
Comment 8 Jason M. Abels 2003-06-27 13:01:02 PDT
duplicate

*** This bug has been marked as a duplicate of 131456 ***

Note You need to log in before you can comment on or make changes to this bug.