Unable to use Basic Authentication

VERIFIED DUPLICATE of bug 6144

Status

()

P3
major
VERIFIED DUPLICATE of bug 6144
19 years ago
19 years ago

People

(Reporter: evan, Assigned: gagan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Basic Authentication fails when I attempt it, and the server complains about the
Authentication string it received.


After the first attempt, the username and password fields change color and will
not accept text any more.

Updated

19 years ago
Assignee: don → gagan
Component: Browser-General → Necko

Comment 1

19 years ago
On RedHat 6.0, with Milestone 10, I got the authentication window, and submitted
it (clicked "OK") (this is step 1). It popped up a couple more times (four?
five?) without being able to accept input I dismissed them in either by
clicking cancel, or by closing the dialogs window. I even hit Mozilla's
stop button at one point. The page loaded then loaded, using Basic
Authentication just fine (step 2), although the image on the page didn't load
(it used the alt text instead of the gif). After this, I tried manually typing
the URL to a page on the sub web (this is the same session) and it behaved as in
Step 2 (none of the dialogs allowed input), only it didn't actually load the
page. I tried cancelling the dialog, hitting ok, closing the dialogs window, but
I couldn't get it to actually load the page in the same manner as the last one.
I'd get a more reliable repro case where it actually loads, but my machine's 200
mhtz, and not quite up to Mozilla's present incarnation.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
the basic auth is not persistent right now (ie. the login/passwd is not being
saved for subsequent requests to the same server) have a dupe somewhere.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
*** This bug has been marked as a duplicate of 6144 ***

Comment 4

19 years ago
Resetting QA contact from leger.

Comment 5

19 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
[bugday] yeah. i'm marking verified as this bug is the old basic auth
persistence problem.
You need to log in before you can comment on or make changes to this bug.