Closed Bug 1596052 Opened 11 months ago Closed 11 months ago

if the SendUpdateCanvasForEvent call is for a previous test then ignore it

Categories

(Testing :: Reftest, defect)

Version 3
defect
Not set
normal

Tracking

(firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: tnikkel, Assigned: tnikkel)

Details

Attachments

(1 file)

No description provided.

This is basically what we did in bug 1593171 (Protect against the same test from calling RecordResult more than once in the reftest harness) where we early exit in SendInitCanvasWithSnapshot.

But now we do it in SendUpdateCanvasForEvent too because SendUpdateCanvasForEvent calls SynchronizeForSnapshot which calls setupAsyncScrollOffsets and setupAsyncZoom, both of which get the documentElement of the current doc and operate on it. The problem is that this could be SendUpdateCanvasForEvent call from the previous test operating on the dom of the current test.

I haven't actually observed this, just noticed it while implementing checking of contentRootElement to make sure all cases are covered.

Depends on D51346

Attachment #9108376 - Attachment description: Bug 1596052. If the SendUpdateCanvasForEvent call is for a previous test then ignore it. r?mattwoodrow → Bug 1596052. If the SendUpdateCanvasForEvent call is for a previous test then ignore it. r=mattwoodrow
Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b9737a17de36
If the SendUpdateCanvasForEvent call is for a previous test then ignore it. r=mattwoodrow
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.