Closed Bug 1596099 Opened 1 year ago Closed 1 year ago

Perma toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Some console message should be generated - - when Gecko 72 merges to Beta on 2019-12-02

Categories

(Core :: Privacy: Anti-Tracking, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 + verified

People

(Reporter: cbrindusan, Assigned: ehsan)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central as Beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cusercancel%2Crunnable&revision=b2065c72984a720647e3d9b1def3365dc042234f&selectedJob=275990106

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=275990106&repo=try&lineNumber=4202

[task 2019-11-13T11:45:05.615Z] 11:45:05 INFO - TEST-START | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js
[task 2019-11-13T11:45:08.628Z] 11:45:08 INFO - TEST-INFO | started process screentopng
[task 2019-11-13T11:45:09.100Z] 11:45:09 INFO - TEST-INFO | screentopng: exit 0
[task 2019-11-13T11:45:09.100Z] 11:45:09 INFO - Buffered messages logged at 11:45:05
[task 2019-11-13T11:45:09.100Z] 11:45:09 INFO - Entering test bound
[task 2019-11-13T11:45:09.100Z] 11:45:09 INFO - Starting blocking cookieBehavior (4) without allow list test Storage Access API called in a sandboxed iframe running in a normal window with iframe sandbox set to allow-scripts allow-same-origin allow-popups and access removal set to null
[task 2019-11-13T11:45:09.100Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | callbackAfterRemoval must be passed when accessRemoval is non-null -
[task 2019-11-13T11:45:09.100Z] 11:45:09 INFO - Creating a new tab
[task 2019-11-13T11:45:09.101Z] 11:45:09 INFO - Creating a 3rd party content
[task 2019-11-13T11:45:09.101Z] 11:45:09 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.net/browser/toolkit/components/antitracking/test/browser/page.html" line: 0}]
[task 2019-11-13T11:45:09.101Z] 11:45:09 INFO - Buffered messages logged at 11:45:06
[task 2019-11-13T11:45:09.101Z] 11:45:09 INFO - Sending code to the 3rd party content
[task 2019-11-13T11:45:09.101Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | requestStorageAccess should not throw - true == true -
[task 2019-11-13T11:45:09.101Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Should not have worked without user interaction - true == true -
[task 2019-11-13T11:45:09.101Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Doesn't yet have storage access - true == true -
[task 2019-11-13T11:45:09.101Z] 11:45:09 INFO - Let's interact with the tracker
[task 2019-11-13T11:45:09.101Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Should not have storage access now - true == true -
[task 2019-11-13T11:45:09.101Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | requestStorageAccess should not throw - true == true -
[task 2019-11-13T11:45:09.101Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | requestStorageAccess shouldn't be available - true == true -
[task 2019-11-13T11:45:09.101Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | No console messages should be generated -
[task 2019-11-13T11:45:09.109Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Checking cookie blocking notifications -
[task 2019-11-13T11:45:09.109Z] 11:45:09 INFO - Removing the tab
[task 2019-11-13T11:45:09.110Z] 11:45:09 INFO - Leaving test bound
[task 2019-11-13T11:45:09.110Z] 11:45:09 INFO - Entering test bound
[task 2019-11-13T11:45:09.110Z] 11:45:09 INFO - Cleaning up.
[task 2019-11-13T11:45:09.111Z] 11:45:09 INFO - Leaving test bound
[task 2019-11-13T11:45:09.111Z] 11:45:09 INFO - Entering test bound
[task 2019-11-13T11:45:09.111Z] 11:45:09 INFO - Starting blocking cookieBehavior (4) without allow list test Storage Access API called in a sandboxed iframe with allow-storage-access-by-user-activation running in a normal window with iframe sandbox set to allow-scripts allow-same-origin allow-popups allow-storage-access-by-user-activation and access removal set to null
[task 2019-11-13T11:45:09.112Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | callbackAfterRemoval must be passed when accessRemoval is non-null -
[task 2019-11-13T11:45:09.112Z] 11:45:09 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "https://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdPartyOpenUI.html?messageme" line: 0}]
[task 2019-11-13T11:45:09.113Z] 11:45:09 INFO - Buffered messages logged at 11:45:07
[task 2019-11-13T11:45:09.113Z] 11:45:09 INFO - Creating a new tab
[task 2019-11-13T11:45:09.113Z] 11:45:09 INFO - Creating a 3rd party content
[task 2019-11-13T11:45:09.114Z] 11:45:09 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.net/browser/toolkit/components/antitracking/test/browser/page.html" line: 0}]
[task 2019-11-13T11:45:09.114Z] 11:45:09 INFO - Sending code to the 3rd party content[task 2019-11-13T11:45:09.114Z] 11:45:09 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “https://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdParty.html” was blocked because it came from a tracker and content blocking is enabled." {file: "http://example.net/browser/toolkit/components/antitracking/test/browser/page.html" line: 35 column: 21 source: "https://example.com/browser/toolkit/components/antitracking/test/browser/storageAccessAPIHelpers.js"}]
[task 2019-11-13T11:45:09.117Z] 11:45:09 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “https://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdParty.html” was blocked because it came from a tracker and content blocking is enabled." {file: "http://example.net/browser/toolkit/components/antitracking/test/browser/page.html" line: 35 column: 21 source: "https://example.com/browser/toolkit/components/antitracking/test/browser/storageAccessAPIHelpers.js"}]
[task 2019-11-13T11:45:09.117Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | requestStorageAccess should not throw - true == true -
[task 2019-11-13T11:45:09.118Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Should not have worked without user interaction - true == true -
[task 2019-11-13T11:45:09.120Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Doesn't yet have storage access - true == true -
[task 2019-11-13T11:45:09.121Z] 11:45:09 INFO - Let's interact with the tracker
[task 2019-11-13T11:45:09.122Z] 11:45:09 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “https://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdParty.html” was blocked because it came from a tracker and content blocking is enabled." {file: "http://example.net/browser/toolkit/components/antitracking/test/browser/page.html" line: 179 column: 11 source: "https://example.com/browser/toolkit/components/antitracking/test/browser/storageAccessAPIHelpers.js"}]
[task 2019-11-13T11:45:09.122Z] 11:45:09 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “https://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdParty.html” was blocked because it came from a tracker and content blocking is enabled." {file: "http://example.net/browser/toolkit/components/antitracking/test/browser/page.html" line: 128 column: 17 source: "resource://specialpowers/WrapPrivileged.jsm"}]
[task 2019-11-13T11:45:09.124Z] 11:45:09 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "https://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdPartyOpenUI.html?messageme" line: 0}]
[task 2019-11-13T11:45:09.124Z] 11:45:09 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “https://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdParty.html” was blocked because it came from a tracker and content blocking is enabled." {file: "http://example.net/browser/toolkit/components/antitracking/test/browser/page.html" line: 99 column: 17 source: "https://example.com/browser/toolkit/components/antitracking/test/browser/storageAccessAPIHelpers.js"}]
[task 2019-11-13T11:45:09.124Z] 11:45:09 INFO - Console message: [JavaScript Warning: "Storage access granted for tracker “https://tracking.example.org” on “https://tracking.example.org”." {file: "https://tracking.example.org/browser/toolkit/components/antitracking/test/browser/3rdParty.html" line: 0}]
[task 2019-11-13T11:45:09.126Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Should have storage access now - true == true -
[task 2019-11-13T11:45:09.127Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | requestStorageAccess should not throw - true == true -
[task 2019-11-13T11:45:09.127Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | requestStorageAccess should be available - true == true -
[task 2019-11-13T11:45:09.128Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Some console message should be generated -
[task 2019-11-13T11:45:09.128Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Message should be of expected category -
[task 2019-11-13T11:45:09.129Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Message should be of expected category -
[task 2019-11-13T11:45:09.129Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Message should be of expected category -
[task 2019-11-13T11:45:09.130Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Message should be of expected category -
[task 2019-11-13T11:45:09.131Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Message should be of expected category -
[task 2019-11-13T11:45:09.131Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Checking cookie blocking notifications -
[task 2019-11-13T11:45:09.131Z] 11:45:09 INFO - Removing the tab
[task 2019-11-13T11:45:09.132Z] 11:45:09 INFO - Leaving test bound
[task 2019-11-13T11:45:09.132Z] 11:45:09 INFO - Entering test bound
[task 2019-11-13T11:45:09.133Z] 11:45:09 INFO - Cleaning up.
[task 2019-11-13T11:45:09.134Z] 11:45:09 INFO - Buffered messages logged at 11:45:08
[task 2019-11-13T11:45:09.134Z] 11:45:09 INFO - Leaving test bound
[task 2019-11-13T11:45:09.134Z] 11:45:09 INFO - Entering test bound
[task 2019-11-13T11:45:09.135Z] 11:45:09 INFO - Starting blocking cookieBehavior (4) without allow list test Verify that sandboxed contexts don't get the saved permission running in a normal window with iframe sandbox set to allow-scripts allow-same-origin allow-popups and access removal set to null
[task 2019-11-13T11:45:09.135Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | callbackAfterRemoval must be passed when accessRemoval is non-null -
[task 2019-11-13T11:45:09.136Z] 11:45:09 INFO - Creating a new tab
[task 2019-11-13T11:45:09.137Z] 11:45:09 INFO - Creating a 3rd party content
[task 2019-11-13T11:45:09.137Z] 11:45:09 INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.net/browser/toolkit/components/antitracking/test/browser/page.html" line: 0}]
[task 2019-11-13T11:45:09.137Z] 11:45:09 INFO - Sending code to the 3rd party content
[task 2019-11-13T11:45:09.139Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Doesn't yet have storage access - true == true -
[task 2019-11-13T11:45:09.139Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | LocalStorage cannot be used! - true == true -
[task 2019-11-13T11:45:09.139Z] 11:45:09 INFO - TEST-PASS | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | We want a security error message. - true == true -
[task 2019-11-13T11:45:09.140Z] 11:45:09 INFO - Buffered messages finished
[task 2019-11-13T11:45:09.141Z] 11:45:09 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/antitracking/test/browser/browser_storageAccessSandboxed.js | Some console message should be generated -

Flags: needinfo?(ehsan)

So it turns out that this test is just failing at the moment, but it is being skipped based on serviceworkers_e10s in browser.ini which bug 1456995 turned on in Nightly. That is why the test isn't failing on trunk (it's just not running there) and it is going to end up running for the first time on beta which means we'll see the breakage there for the first time.

Flags: needinfo?(ehsan)

The logic for this change was discussed in
https://bugzilla.mozilla.org/show_bug.cgi?id=1558420#c24, but this test
wasn't updated at the same time because it was disabled by default...

Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3aa81d10fb7e
Don't expect a window.open() call from a sandboxed iframe to generate notifications saying a tracking cookie was blocked; r=nhnt11
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.