Closed Bug 1596116 Opened 1 year ago Closed 6 months ago

Picture in Picture not correctly displayed or not displayed all when clicking the PiP button before the video starts

Categories

(Toolkit :: Video/Audio Controls, defect, P2)

Desktop
All
defect

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- wontfix
firefox80 --- fixed
firefox81 --- fixed
firefox82 --- fixed

People

(Reporter: atrif, Unassigned)

References

(Blocks 1 open bug)

Details

Affected versions

  • 71.0b9 (20191111170815)
  • 72.0a1 (20191112214946)
  • 70.0.1 (20191030021342)

Affected platforms

  • Ubuntu 18.04
  • macOS 10.14
  • Windows 10x64

Steps to reproduce

  1. Open Firefox and go to https://shaka-player-demo.appspot.com/demo/#asset=https://storage.googleapis.com/shaka-demo-assets/angel-one/dash.mpd;lang=en-US;build=uncompiled.
  2. Select “Play” from “Big Buck Bunny: the Dark Truths” video.
  3. Quickly select the Picture-in-Picture button.

Expected result

  • Picture in picture is correctly shown.

Actual result

  • On single monitor, the PiP video player is nowhere to be found.
  • On dual monitors the PiP video player is positioned on the second monitor as seen in this screenshot.

Regression range

  • Reproducible with Firefox 68.0a1(20190502220333). I will search for one ASAP if there is one.

Additional Notes

  • Attached a screen recording with the issue.
  • The issue only happens if the PiP button is clicked very fast after selecting “Play”. Also, the issue is reproducing for the “Sintel” video too.
Has Regression Range: --- → no
Has STR: --- → yes

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

I have observed a similar problem, when trying to start pip on a video that has not yet loaded.
When I do that, the video canvas is blanked telling me to look for the actual video someplace else. But the pip-window in the bottom-left has not been created, possibly because the video has not started playing yet

I suppose Firefox should either refuse to start pip or open a pip with a loading screen

Possibly related error message in console:

InvalidStateError: An attempt was made to use an object that is not, or is no longer, usable @ PictureInPictureChild.jsm:92

(In reply to Frederik Braun [:freddyb] from comment #2)

I have observed a similar problem, when trying to start pip on a video that has not yet loaded.

Yep, thanks for the tip. I can easily reproduce this on youtube by limiting the internet connection, select a random video and activate PiP while the circle is spinning (the video is loading).

That being said I tried searching for a regression range on Windows 10x64, but I didn't find one because the issue is happening way back to Firefox 67.0a1 (20190212195904), which is the last build that has "media.videocontrols.picture-in-picture.enabled" pref for picture in picture. So I think it's safe to assume that the issue is not a regression. Removing the flags.

Has Regression Range: no → ---

Also reproducible on Firefox 67.0b3 and below. Happened on macOS 10.15.

I could no longer replicate the bug. I used mozregression to find where the bug was fixed.
morzregression information below.
276:49.18 INFO: Narrowed integration regression window from [fe4b1b62, d8036a25] (3 builds) to [fe4b1b62, 4184cfc0] (2 builds) (~1 steps left)
276:49.18 INFO: No more integration revisions, bisection finished.
276:49.18 INFO: First good revision: 4184cfc09c3afbf1934047808fd8a1bedf8ad374
276:49.18 INFO: Last bad revision: fe4b1b625e77c365ede54c15bca6e1ab23d234e1
276:49.18 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=fe4b1b625e77c365ede54c15bca6e1ab23d234e1&tochange=4184cfc09c3afbf1934047808fd8a1bedf8ad374

Thanks, Niklas! Resolving!

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
You need to log in before you can comment on or make changes to this bug.