Closed Bug 1596133 Opened 3 months ago Closed 3 months ago

AbuseReporter.queryAMOAddonDetails should normalize type 'statictheme' into type 'theme'

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox71 --- verified
firefox72 --- verified

People

(Reporter: rpl, Assigned: rpl)

Details

Attachments

(1 file)

The addon details returned from the AMO API endpoint for webextensions static themes is type "statictheme", but for an installed WebExtension static theme we expect addon.type to be "theme".

AbuseReporter.queryAMOAddonDetails should normalize the type received to ensure it matches what Firefox expects.

This fix is needed to ensure that reporting a "not installed" theme from AMO works as expected (see https://github.com/mozilla/addons-frontend/issues/8762#issuecomment-553430081).

Assignee: nobody → lgreco
Status: NEW → ASSIGNED
Priority: -- → P1

The addon details returned from the AMO API endpoint for webextensions static themes is type "statictheme",
but for an installed WebExtension static theme we expect addon.type to be "theme", and so
AbuseReporter.queryAMOAddonDetails should normalize the type received to ensure it matches what
Firefox expects.

This fix is needed to ensure that reporting a "not installed" theme from AMO works as expected
(see https://github.com/mozilla/addons-frontend/issues/8762#issuecomment-553430081).

Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/c3630e8d5837
AbuseReporter.queryAMOAddonDetails should normalize type 'statictheme' into type 'theme'. r=mixedpuppy

Comment on attachment 9108426 [details]
Bug 1596133 - AbuseReporter.queryAMOAddonDetails should normalize type 'statictheme' into type 'theme'. r?mixedpuppy!

Beta/Release Uplift Approval Request

  • User impact if declined: Without this fix addons.mozilla.org would not be able to hand-off the abuse reporting to the Firefox integrated abuse report panel for themes
    (because mozAddonManager.reportAbuse would cancel automatically the report request for a theme that is not currently installed in that Firefox instance).
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Yes, the fix should be QA verified on nightly (as soon as it reached mozilla-central), and then also on beta if this uplift request is being accepted.
    The fix should be verified using the STR being used as part of the "AMO abuse reporting" QA verification test plan on a "not installed" static theme.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The fix is a single line change (to normalize the type: "statictheme" received from the AMO addon details API endpoint into type: "theme" as expected for a static theme already installed in the Firefox instance), the part of the code affected does only impact the reports created for addons not installed (and so it can also only be triggered by AMO using the mozAddonManager.reportAbuse API exposed to it).

The fix is also paired with a new test case as part of the rest of the abuse reporting test cases.

  • String changes made/needed:
Attachment #9108426 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
QA Whiteboard: [qa-triaged]

Verified as fixed in Latest Nightly FF 72.0a1 (2019-11-15)

Abuse reporting are returning now True for Themes.

Status: RESOLVED → VERIFIED

Comment on attachment 9108426 [details]
Bug 1596133 - AbuseReporter.queryAMOAddonDetails should normalize type 'statictheme' into type 'theme'. r?mixedpuppy!

P1, low risk with tests and verified by QA on nightly, uplift approved for 71 beta 11, thanks.

Attachment #9108426 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified as fixed in FF 71.0b11

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.