quips should be editable and deleteable using the web interface

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
User Interface
P4
minor
RESOLVED FIXED
16 years ago
6 years ago

People

(Reporter: Tobias Burnus, Assigned: Tobias Burnus)

Tracking

2.17
Bugzilla 2.18
Bug Flags:
approval +

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

16 years ago
Until recently the quips had been stored in data/comments. Now they have been
moved into the database it had become much more difficult to delete (or change)
quips. The problem is that quips can be added by anyone (needn't to be logged
in/anonymous) which potentially increases the number of obscene or offensive quips .

Don't know who should be able to edit/delete them. At least the admin should to
so for sure.
This is a fair point - although the userid of the person who contributes the
quip is now logged.

I think disabling anonymous quip contribution (without any sort of pref) is
perfectly reasonable. quips should be by regular users for regular users. If you
want to add a quip, get an account.

Gerv
Assignee: myk → gerv
Target Milestone: --- → Bugzilla 2.18
Didn't someone disable anonymous quip submission last week? I thought I saw that
bug go by somewhere.
Yep, we did that. But this bug is still valid.

Gerv
(Assignee)

Comment 4

16 years ago
Make sure that this doesn't get lost (bug 67950 comment 27):
> Once the groups system gets rewritten we should add 'addquips' and
> 'removequips' groups.
(this makes of cause only sense if bug 157756 gets checked in first, but maybe
instead of 'removequips' it should be 'editquips')
I disagree that these two things require groups. Quips are not important enough
for it to be worth the added complexity. addquips should be equivalent to
editbugs, and editquips should be equivalent to some admin-level group.

Gerv
(Assignee)

Comment 6

16 years ago
> addquips should be equivalent to editbugs, and editquips should be equivalent to 
> some admin-level group.
For our use it would be also ok if anyone who has logged in an add quips.
Well given the plan is for editbugs to go away and be replaced with a fine
grained system, it seems kind of silly to say editbugs is enough.

And the chance of multiple installations not wanting to set up a different add
quips group is almost nil.
What I said was a shorthand for the following:

Quips are a trivial and fun part of Bugzilla; as far as possible, they should
fit in with what's going on without requiring special consideration. It
therefore seems sane to make "addquips" equivalent to some sort of semi-trusted
role like editbugs, and "editquips" equivalent to some sort of
semi-administrator role. Whichever roles are appropriate in the new scheme could
be used. 

I doubt very much that any admin cares about quips enough to want to set up a
special group of people who are permitted to add them or edit them. We just want
a sensible scheme which means random people can't insert rude/offensive quips.

Gerv
*** Bug 163769 has been marked as a duplicate of this bug. ***
I am assigning all the bugs I am not working on in the immediate future to
nobody@bugzilla.org. This means:

- I will be able to search for bugs assigned to me as a list of bugs I'm going
to fix (which is as it should be), and
- people won't falsely assume I might be about to fix a bug when I'm not.

Gerv
Assignee: gerv → nobody
(Assignee)

Comment 11

16 years ago
-> Me
Assignee: nobody → burnus
(Assignee)

Comment 12

16 years ago
Created attachment 108668 [details] [diff] [review]
v1: Add ability to delete a quip

This adds the ability to delete a quip. Since the deleted quip is shown, one
can edit it by adding the modified quip, which should be sufficient.
I use the group "admin" as group which can delete quips.
(Assignee)

Comment 13

16 years ago
Created attachment 108669 [details] [diff] [review]
v1.1: Fix tiny nits by timeless
Attachment #108668 - Attachment is obsolete: true
(Assignee)

Comment 14

16 years ago
Created attachment 108682 [details] [diff] [review]
v1.2: Fix spacing & use "unless" which saves one line & change code-error text (makes timeless happy)

(I really need to learn counting to four/two for indenting.
Btw: Do you know this joke: "There are three types of mathematicians: One part
can count up to three, the others cannot.")
Attachment #108669 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Attachment #108682 - Flags: review?(bbaetz)

Comment 15

16 years ago
Comment on attachment 108682 [details] [diff] [review]
v1.2: Fix spacing & use "unless" which saves one line & change code-error text (makes timeless happy)

i'm happy, sorry about the extra diffs..
Attachment #108682 - Flags: review?(bbaetz) → review+
(Assignee)

Updated

16 years ago
Flags: approval?
Flags: approval? → approval+

Updated

16 years ago
Blocks: 184309

Comment 16

16 years ago
Checked in for Burnus

Checking in quips.cgi;
/cvsroot/mozilla/webtools/bugzilla/quips.cgi,v  <--  quips.cgi
new revision: 1.16; previous revision: 1.15
done
Checking in template/en/default/global/code-error.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/code-error.html.tm
pl,v  <--  code-error.html.tmpl
new revision: 1.24; previous revision: 1.23
done
Checking in template/en/default/global/user-error.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/user-error.html.tm
pl,v  <--  user-error.html.tmpl
new revision: 1.25; previous revision: 1.24
done
Checking in template/en/default/list/quips.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/list/quips.html.tmpl,v  <
--  quips.html.tmpl
new revision: 1.7; previous revision: 1.6
done                                        
No longer blocks: 184309
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Priority: -- → P4
Resolution: --- → FIXED
Er... did no-one think of suggesting that we use the current big quip list and
add a "delete" link for each if the user is an admin, rather than duplicating
the code which reads all the quips in from the database?

Gerv
burnus, justdave: ping?

Gerv
nope, apparently nobody thought of that.
Right. So, shall we do that, then? :-)

Gerv
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.