Closed Bug 1596310 Opened 3 months ago Closed 3 months ago

ASSERTION: unexpected max block size: 'aBSize >= 0'

Categories

(Core :: Layout, defect, P3, minor)

x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- wontfix
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- fixed

People

(Reporter: mats, Assigned: mats)

References

Details

(Keywords: assertion, testcase)

Attachments

(2 files)

Attached file Testcase

STR

  1. load the attached testcase in a DEBUG build
  2. open Print Preview

ACTUAL RESULTS

###!!! ASSERTION: unexpected max block size: 'aBSize >= 0', file layout/generic/nsFloatManager.cpp, line 110
###!!! ASSERTION: illegal height for combined area: 'aOverflowAreas.Overflow(otype).height >= 0', file layout/generic/nsLineBox.cpp, line 535
###!!! ASSERTION: illegal height for combined area: 'aOverflowAreas.Overflow(otype).height >= 0', file layout/generic/nsLineBox.cpp, line 535

Blocks: 471015

FWIW, I cannot reproduce this bug with the testcase attached in comment 0, but I can with the crashtest in the patch. Instead of STR step 2, using "Toggle -> Paged Mode" in the layout debugger can trigger the assertions as well.

That's odd. It does reproduce it for me on Linux using a fresh profile. That test uses 100vh though which I realized is quite buggy in any paginated mode (see my comments in bug 1414600). So I switched to using 100% instead for the tests in the patch since it appears more reliable. (I also have a couple of tests for bug 471015 that trigger the assertion without this patch, fwiw).

Pushed by mpalmgren@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c1d9e657897e
Clamp negative available size to zero and ensure page break frames don't apply margins.  r=TYLin
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.