Closed Bug 1596391 Opened 5 months ago Closed 5 months ago

Remove some more dead XBL code.

Categories

(Core :: DOM: Core & HTML, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 2 open bugs)

Details

Attachments

(5 files)

This makes bug 1596209 easier.

BL is gone, and thus we don't need to check for the children element anymore,
and computing it upfront becomes cheap.

Depends on D52990

Always returns false.

Depends on D52991

They're dead.

Depends on D52992

Never set anymore.

Depends on D52993

Priority: -- → P3
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1dc82629b31e
Remove a dead style system function. r=smaug
https://hg.mozilla.org/integration/autoland/rev/853ed67836c6
Remove lazy computation of FlattenedChildIterator::mXBLInvolved. r=smaug
https://hg.mozilla.org/integration/autoland/rev/f6794e4da7e8
Remove nsIContent::IsActiveChildrenElement. r=smaug
https://hg.mozilla.org/integration/autoland/rev/8029fe5cc2a1
Remove Get/SetXBLInsertionPoint. r=smaug
https://hg.mozilla.org/integration/autoland/rev/3a1f314c3022
Remove NODE_MAY_BE_IN_BINDING_MNGR. r=smaug
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/3af7f65785fe
Fix silly boolean logic mistake. r=bustage a=dluca
Duplicate of this bug: 1596197
You need to log in before you can comment on or make changes to this bug.