File saved with wrong extension if I shift-left-click link to PDF file

VERIFIED INVALID

Status

Core Graveyard
File Handling
VERIFIED INVALID
16 years ago
a year ago

People

(Reporter: Rich Griswold, Assigned: Bill Law)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1b) Gecko/20020724
BuildID:    2002072422

When I save a PDF file by holding shift while left-clicking on the link to file,
the filename has an extra "..pdf" appended.  If I just left-click and select
"Save this file to disk", then the file name is correct.  This only seems to
happen with files that have an extension of ".pdf".  I've also confirmed that
this happens even if the file isn't actually a PDF file (for example, if a plain
text file has an extension of .pdf).

I've tried this test with other links to files with other extensions, such as
.tar.gz and .xpm files, and they have the correct file name.

The workaround for this problem is to delete the extra "..pdf", or to not hold
the shift key down when left-clicking and select "Save this file to disk".

Reproducible: Always
Steps to Reproduce:
1. Find a page with a link to a PDF file.
2. Hold the shift key and left-click on the link.
3. "Save As" dialog pops up with incorrect file name.

Actual Results:  "Save As" dialog has the wrong file name.  For the URL listed
above, the file name is "test.pdf..pdf".

Expected Results:  File name should be "test.pdf".

*** This bug has been marked as a duplicate of 120327 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

15 years ago
This bug was closed as a dup of bug 120327, and that bug "is fixed, and it is
now dead. Do not reopen."  However, the problem with PDF files persists on
Mozilla for Solaris.  I am using the latest daily build, and I can reproduce it
using the URL listed in the bug header.  This problem no longer happens with
Mozilla on Linux, so I'm not sure why it persists with Solaris.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

15 years ago
Using build id 20030212 on solaris 8/sparc. When I shift-leftclick on the PDF
link, mozilla offers to save the file as "test.pdf". I click OK and the file is
saved under that name.

Rich, could you try this with a current version of mozilla and see if you can
reproduce the behavior you describe?
(Reporter)

Comment 5

15 years ago
I tracked the problem down to a defective mimeTypes.rdf in my ~/.mozilla
directory.  I removed the file and the problem went away.  I'm not sure when the
PDF entry was added to the file, since I didn't do it myself...

Sorry for the trouble.

Comment 6

15 years ago
Resolving. Thanks for the update, Rich!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → INVALID
v per reporter.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.