Closed Bug 1597038 Opened 3 months ago Closed 3 months ago

Crash in [@ mozilla::dom::indexedDB::`anonymous namespace'::Cursor::SendResponseInternal]

Categories

(Core :: Storage: IndexedDB, defect)

72 Branch
Unspecified
Windows 10
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- fixed

People

(Reporter: philipp, Assigned: sg)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file, 1 obsolete file)

This bug is for crash report bp-625d1754-e3e5-4a1f-8f94-787a30191115.

Top 10 frames of crashing thread:

0 xul.dll void mozilla::dom::indexedDB::`anonymous namespace'::Cursor::SendResponseInternal dom/indexedDB/ActorsParent.cpp:15311
1 xul.dll bool mozilla::dom::indexedDB::`anonymous namespace'::Cursor::CursorOpBase::SendFailureResult dom/indexedDB/ActorsParent.cpp:25741
2 xul.dll void mozilla::dom::indexedDB::`anonymous namespace'::TransactionDatabaseOperationBase::SendPreprocessInfoOrResults dom/indexedDB/ActorsParent.cpp:22177
3 xul.dll nsresult mozilla::dom::indexedDB::`anonymous namespace'::TransactionDatabaseOperationBase::Run dom/indexedDB/ActorsParent.cpp
4 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1250
5 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:486
6 xul.dll mozilla::ipc::MessagePumpForNonMainThreads::Run ipc/glue/MessagePump.cpp:333
7 xul.dll void MessageLoop::RunHandler ipc/chromium/src/base/message_loop.cc:308
8 xul.dll MessageLoop::Run ipc/chromium/src/base/message_loop.cc:290
9 xul.dll static void nsThread::ThreadFunc xpcom/threads/nsThread.cpp:458

this browser crash signature is showing up recently since 72.0a1 build 20191114214957 - likely regressed by the changes from bug 1168606.
the crashes are happening with the optimisitic MOZ_CRASH("Should never get here!"); from bug 994190.

(so far, all crashes got reported from win10 machines with nvidia gpus - i'm not sure yet if this a coincidence at this point)

I'm experiencing this bug. Win10x64 with an Nvidia GPU, guaranteed crash on startup. Let me know if I can help.

Assignee: nobody → sgiesecke
Status: NEW → ASSIGNED
Duplicate of this bug: 1596785
Crash Signature: [@ mozilla::dom::indexedDB::`anonymous namespace'::Cursor::SendResponseInternal] → [@ mozilla::dom::indexedDB::`anonymous namespace'::Cursor::SendResponseInternal] [@ mozilla::dom::indexedDB::(anonymous namespace)::Cursor::SendResponseInternal]
Pushed by sgiesecke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/561598bb2f39
Fix crash in Cursor::SendResponseInternal with nsresult response type and non-empty files. r=dom-workers-and-storage-reviewers,ttung
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

After the fix, no new crash reports have been submitted so far.

mitchell, can you confirm your startup works again with the new Nightly?

Flags: needinfo?(mitchell)

Yes, no crashes since the fix was landed. Thanks for fixing and for checking up :)

I'm not too familiar with etiquette in these situations, should I have chimed in as soon as I tried the fix?

Flags: needinfo?(mitchell)
Attachment #9109929 - Attachment is obsolete: true

Great, thanks!

I am not sure what is customary either :) Personally, I think it might help if you report back if you tried it. It might be that the crash disappeared but some other problem turned up instead, and we would have no way of knowing.

Attachment #9109929 - Attachment is obsolete: false
Attachment #9109929 - Attachment is obsolete: true

Hi Simon, is qa needed here? And if so, could you provide us with some steps? Thanks!

Flags: needinfo?(sgiesecke)

(In reply to Catalin Sasca, QA [:csasca] from comment #10)

Hi Simon, is qa needed here? And if so, could you provide us with some steps? Thanks!

Unfortunately, I can't provide any steps to reproduce the issue. We are considering adding more automated unit tests for the parent process code in isolation to better catch such things in the future.

Flags: needinfo?(sgiesecke)
You need to log in before you can comment on or make changes to this bug.