Closed Bug 1597086 Opened 11 months ago Closed 10 months ago

Long search bar queries make search popup wider than search box

Categories

(Firefox :: Search, defect, P1)

defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 72
Iteration:
72.3 - Nov 18 - Dec 1
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 + verified

People

(Reporter: yoasif, Assigned: mak)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

STR:

  1. Enable separate search bar
  2. Search for "What Chinese Officials Told Children Whose Families Were Put in Camps"
  3. Do Control-k
  4. Type "wha"

What happens:

The search suggestion "What Chinese Officials Told Children Whose Families Were Put in Camps" appears, but the popup is wider than the search box.

Expected result:

As before; search popup should have same width as search box.

7:03.29 INFO: No more inbound revisions, bisection finished.
7:03.29 INFO: Last good revision: a92020c2ec43f3b3a66b142e36456e2849c0217b
7:03.29 INFO: First bad revision: 32f7be1fc656e438aee8406cb429abc67bf443b6
7:03.29 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=a92020c2ec43f3b3a66b142e36456e2849c0217b&tochange=32f7be1fc656e438aee8406cb429abc67bf443b6

[Tracking Requested - why for this release]: Regression in a visible part of the search UI.

Has Regression Range: --- → yes
Has STR: --- → yes
Regressed by: 1584253

This is surprising, I only touched the one-off container styling and this seems to be a problem with the results container. Probably the flexible display confuses layout.

Assignee: nobody → mak
Status: NEW → ASSIGNED
Iteration: --- → 72.3 - Nov 18 - Dec 1
Points: --- → 2
Priority: -- → P1
Component: Address Bar → Search

Wrapping one-off buttons into a container confuses layout that lets the richlist
box to grow unconditionally. This problem is already partially visible by
opening the searchbar continuously, sometimes strings are not properly overflowing
with ellipsis, they are just overflowing.
Setting a width on the panel limits its size properly, though this won't fix the
layout sometimes not properly cutting the richlistbox. It's likely there an
underlying bug in the widget or calculations when widgets are not visible.

This also correctly forces showing at least 3 one-off buttons per row, the
existing code is not sufficient for that because search-one-offs.js sets a
max-width that is smaller than 3 buttons.

Similarly, it corrects a calculation in the urlbar one-offs, where we should
show at least 4 buttons, but due to a not considered margin we only show 3.

Finally, this removes a few rules that are not necessary with the current design.

Blocks: 1599081
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/f912ca0ab78b
Limit size of the search bar panel. r=Standard8
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Flags: qe-verify+

Reproduced the issue using Firefox 72.0a1 (20191117213438) on Windows 10x64.
The issue is verified fixed on Windows 10x64, macOS 10.15 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.