Closed Bug 1597265 Opened 3 months ago Closed 3 months ago

Pressing Enter right after opening the abuse report dialog window should cancel the report

Categories

(Toolkit :: Add-ons Manager, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox71 --- verified
firefox72 --- verified

People

(Reporter: rpl, Assigned: rpl)

Details

Attachments

(1 file)

QA reported to me today that they noticed the following behavior:
if Enter is pressed right after the report dialog has been open, then the report dialog is being closed and the report cancelled.

I reproduced the issue locally to look into the underlying reason and I did notice that (once the dialog window has been just opened) pressing Enter is triggering a click event with the "close icon button" as the target (which is actually hidden when the report is open as a dialog, because it is redundant with the close icon already provided by the operating system on the dialog window itself) and handling that click event is what is cancelling the report dialog:

Assignee: nobody → lgreco
Status: NEW → ASSIGNED
Priority: -- → P1
Blocks: 1580554
Attachment #9109643 - Attachment description: Bug 1597265 - Disable abuse report close icon button when it is hidden. r?mstriemer! → Bug 1597265 - Explicitly mark abuse report panel buttons as type button. r?mstriemer!
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/f9cababa8a63
Explicitly mark abuse report panel buttons as type button. r=mstriemer

Removed reference to Bug 1580554: the issue was there even before the changes applied by Bug 1580554, we just missed to notice it before.

No longer blocks: 1580554
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Hello,

Verified the fix on the latest Nightly (72.0a1/20191120094758) under Windows 10 Pro 64-bit and MacOS Catalina 10.15.

Pressing Enter after the abuse report dialog opens no longer closes the window and cancels the report, confirming the fix.

Status: RESOLVED → VERIFIED

Comment on attachment 9109643 [details]
Bug 1597265 - Explicitly mark abuse report panel buttons as type button. r?mstriemer!

Beta/Release Uplift Approval Request

  • User impact if declined: If the user press enter right after the abuse report panel is open (both if opened as a subframe of the about:addons tab, or as a dialog window when extensions.abuseReport.openDialog is true), the abuse report is closed immediately as user cancelled.

It isn't a super big deal, because the user could re-open the panel again, but it would be surprising.

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Same STR used to verify it on Nightly.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The patch only adds an explicit type="button" to the buttons that are part of the report panel, and so it is impact is limited to the abuse report panel.
    No other changes have been needed to fix the issue.

The patch does also include a new test case to ensure the fix doesn't regress.

  • String changes made/needed:
Attachment #9109643 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9109643 [details]
Bug 1597265 - Explicitly mark abuse report panel buttons as type button. r?mstriemer!

P1, has tests, was verified by QA and patch looks low risk to me, uplift approved for 71 beta 12, thanks.

Attachment #9109643 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hello,

Verified the fix on the latest Beta (71.0b12/20191121155457) under Windows 10 Pro 64-bit and MacOS Catalina 10.15.

Pressing Enter after the abuse report dialog opens no longer closes the window and cancels the report, confirming the fix.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.