Only first selection in a multiple-selection dropdown list is saved

RESOLVED WONTFIX

Status

()

P3
normal
RESOLVED WONTFIX
17 years ago
10 years ago

People

(Reporter: bdhobbs18, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.1b) Gecko/20020722
BuildID:    2002072203

I'm currently unemployed and visit several job boards for leads.  I thought I
would have Mozilla's form manager fill in the search forms with the values that
I commonly use.  It appears that the forms manager is storing the values
incorrectly.

Reproducible: Always
Steps to Reproduce:
1. tools -> form manager -> edit form info; click remove all saved data button
2. go to http://www.dice.com/jobsearch/
3. make entries - in my case: "vms or openvms or dcl or vax or ingres or rdb",
boolean, first four entries in state list, 7 days, 50 jobs, 2000 matches
4. tools -> form manager -> save form info; click ok button in alert
5. go to http://www.dice.com/jobsearch/
6. tools -> form manager -> fill in form

Actual Results:  Only the first selection in the state list is selected.

tools -> form manager -> edit form info
  primary contact info -> address
    state/prov = All US states
    e-mail = vms or openvms or dcl or vax or ingres or rdb
  primary contact info -> phone numbers
    day = 7
  other saved information -> url specific
    three entries: 50 jobs, 2000 matches, no restrictions taxterm

Expected Results:  I think that all of these form values should have appeared in
the url specific category.  It appears that only the first selected item in a
select list is stored.

Split per http://bugzilla.mozilla.org/show_bug.cgi?id=159676#c2

Comment 1

17 years ago
Confirmed using Mac/2002080208/9.2.2. Simplified reproduction regime:

1. Access [http://www.dice.com/jobsearch/]
2. Select "Telecommute" and "International" in "Restrict by State" menu
3. Do Tools/Form Manager/Save Form Info; dismiss confirmation dialog
4. Do Tools/Form Manager/Edit Form Info/Primary Contact Information/Address

Actual Results:
State has been changed to "Telecommute".

Expected Results:
Multiple selection data should have been stored in Other Saved Information/URL-Specific.

What I might suggest is that, if a menu identified as providing non-URL-specific data such as 
state has the MULTIPLE attribute, it be diverted to Other Saved Information/URL-Specific instead.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: form info not saved properly → Multiple State selection improperly changing Primary Contact Information/State

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Summary: Multiple State selection improperly changing Primary Contact Information/State → Only first selection in a multiple-selection dropdown list is saved
Target Milestone: --- → mozilla1.3alpha
Seems important but also a lot of work. Future for now.

Reassigning to new module owner.
Assignee: morse → dveditz
Status: ASSIGNED → NEW
Target Milestone: mozilla1.3alpha → Future
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
The testcase has been relocated and redesigned, so I can't test this properly. 
I believe, though, that this problem does not occur in MacOS X. 

Because we are not working on anything dealing with old Mac since 1.3.1 anymore,
I mark this "WONTFIX".
In case that it reoccurs in MacOS X, please file a new bug.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Assignee: dveditz → nobody
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: tpreston → form.manager
Target Milestone: Future → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.