Closed Bug 1597434 Opened 2 years ago Closed 6 months ago

Fix uses of nsGlobalWindowInner::FireDelayedDOMEvents in dom/base/nsGlobalWindowInner.cpp

Categories

(Core :: DOM: Navigation, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1698549
Fission Milestone M7a

People

(Reporter: djvj, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [rm-docshell-tree-item:rename], fission-bfcache)

In file dom/base/nsGlobalWindowInner.cpp

Calls FireDelayedDOMEvents on child windows.

Rename to FireInProcessDelayedDomEvents.

Change to using BrowsingContext.

Kannan says replacing nsIDocShellTreeItem calls should block enabling Fission in Nightly (M6).

Fission Milestone: --- → M6
Priority: -- → P3

This is called as part of restoring a document from BFCache, and will probably need to be fixed as part of the session history in parent work.

Blocks: fission-history
No longer blocks: rm-docshell-tree-item

Auditing whether this use of nsIDocShellTreeItem breaks when Fission is enabled blocks Fission Nightly.

Fission Milestone: M6 → M6b
See Also: → 1640768
Fission Milestone: M6b → M6c

BFCache

Fission Milestone: M6c → M7

This will be covered as part of the Fission BFCache redesign.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: fission-bfcache

I think we need to keep this open. This is a separate thing to fix.

Blocks: fission-bfcache
No longer blocks: fission-history
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: [rm-docshell-tree-item:rename] → [rm-docshell-tree-item:rename], fission-bfcache

Moving all M7 Fission BFCache work to M7a.

Fission Milestone: M7 → M7a
Status: REOPENED → RESOLVED
Closed: 8 months ago6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1698549
You need to log in before you can comment on or make changes to this bug.