Closed Bug 1597441 Opened 1 year ago Closed 7 months ago

Fix uses of nsHistory::GetSessionHistory in dom/base/nsHistory.cpp

Categories

(Core :: DOM: Navigation, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1467221

People

(Reporter: djvj, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [rm-docshell-tree-item:session-history])

In file dom/base/nsHistory.cpp

Uses DocShell tree to get root and obtain nsIWebNavigation from that, to retrieve session history.

Used by nsHistory navigation IDL APIs (window.history) - Go, Back, Forward, etc.

For now, change to use BrowsingContext to find root docshell.

SessionHistory work will get around to ensuring it only gets called in situations where the root is in process.

Kannan says replacing nsIDocShellTreeItem calls should block enabling Fission in Nightly (M6).

Fission Milestone: --- → M6
Priority: -- → P3

Auditing whether this use of nsIDocShellTreeItem breaks when Fission is enabled blocks Fission Nightly.

Fission Milestone: M6 → M6b
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: fission-history

Clearing Fission Milestone for bugs resolved as duplicates. We don't need to track duplicates.

Fission Milestone: M6b → ---
You need to log in before you can comment on or make changes to this bug.