Closed Bug 1597447 Opened 1 year ago Closed 4 months ago

Audit nsIDocShellTreeItem usage in nsHTMLDocument::StartDocumentLoad in dom/html/nsHTMLDocument.cpp

Categories

(Core :: DOM: Navigation, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1597398

People

(Reporter: djvj, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [rm-docshell-tree-item:hard])

In file dom/html/nsHTMLDocument.cpp

Uses DocShell tree to get parent item.

Some of the code around this seems to have been fixed for Fission, e.g. the following fix within the call to Document::StartDocumentLoad https://bugzilla.mozilla.org/show_bug.cgi?id=1555050

Obtains the ContentViewer from either the current DocShell or the parent DocShell.

Users of Content-Viewer are conditionalized, and lack of one won’t crash. Might lead to failures in specific tests when the docshell content-viewer is null, and its parent is out of process.

Uses content-viewer exactly twice, here:

Kannan says replacing nsIDocShellTreeItem calls should block enabling Fission in Nightly (M6).

Fission Milestone: --- → M6
Priority: -- → P3
Summary: Fix uses of nsHTMLDocument::StartDocumentLoad in dom/html/nsHTMLDocument.cpp → Audit nsIDocShellTreeItem usage in nsHTMLDocument::StartDocumentLoad in dom/html/nsHTMLDocument.cpp

Auditing whether this use of nsIDocShellTreeItem breaks when Fission is enabled blocks Fission Nightly.

Fission Milestone: M6 → M6b

:hsivonen, this seems to be charset hint related, which you're more familiar with than me. Any thoughts as to what might need to be done here when you get back?

Flags: needinfo?(hsivonen)
Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(hsivonen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1597398

Clearing Fission Milestone for bugs resolved as duplicates. We don't need to track duplicates.

Fission Milestone: M6b → ---
You need to log in before you can comment on or make changes to this bug.