Closed Bug 1597573 Opened 3 months ago Closed 3 months ago

Triqui language only shown as 'trs' in dropdown for accept languages

Categories

(Core :: Internationalization, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed
firefox72 --- fixed

People

(Reporter: aryx, Assigned: flod)

Details

(Keywords: regression)

Attachments

(1 file)

Bug 1583177 added the Triqui language as an option to choose from the list of accept languages in Options > General > Language > Choose your preferred language for displaying pages.

It's only shown as 'trs' in both 71.0b11 and 72.0a1 20191118093852.

trs needs to be added at https://searchfox.org/mozilla-central/rev/131338e5017bc0283d86fb73844407b9a2155c98/toolkit/components/mozintl/mozIntl.jsm#171

Flags: needinfo?(francesco.lodolo)

Unfortunately that's not something I was aware of. Leaving it here for now, to see if someone can pick it up before me.

While not ideal, I don't consider this a blocker, we shipped locales for years without an associated displayed language names.

Flags: needinfo?(francesco.lodolo)

Note: this is not a regression, it's a task that needs to be completed. It was possible to add trs manually to accept-languages before (via about:config), like any other language, and it would show up as the locale code, because there's no language name associated to it.

No longer regressed by: 1583177
Assignee: nobody → francesco.lodolo
Pushed by flodolo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3627a56e5003
Add trs to availableLocaleDisplayNames in mozIntl.jsm r=Pike

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Verified on 72.0a1 (2019-11-19) (64 bit)

Status: RESOLVED → VERIFIED

Comment on attachment 9109892 [details]
Bug 1597573 - Add trs to availableLocaleDisplayNames in mozIntl.jsm

Beta/Release Uplift Approval Request

  • User impact if declined: trs  language is displayed as locale code in the language settings for Web Content
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only adding the locale code to an existing list to pick up the associated language name.
  • String changes made/needed: None
Attachment #9109892 - Flags: approval-mozilla-beta?

Comment on attachment 9109892 [details]
Bug 1597573 - Add trs to availableLocaleDisplayNames in mozIntl.jsm

No risk, uplift approved for 71 beta 12, thanks.

Attachment #9109892 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.