Closed Bug 1597674 Opened 1 year ago Closed 1 year ago

In standalone mail window F6 and TAB generates error message in console

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 verified, seamonkey2.57esr fixed)

RESOLVED FIXED
seamonkey2.69
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- verified
seamonkey2.57esr --- fixed

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Details

(Whiteboard: SM2.53.1)

Attachments

(1 file)

Equivalent SM bug for TB's bug 1597061
STR
1/ Open SeaMonkey
2/ Open message in a standalone window
3/ Press F6 (with or without modifiers) or TAB (with control or control+shift modifiers)

Expected result
1/ No error message in error console

Actual result
1/ Following message in error console:
ReferenceError: SwitchPaneFocus is not defined messageWindow.xul:1:1

Attached file F6 and TAB patch

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: error messages in error console
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None

Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #9109963 - Flags: review?(frgrahl)
Attachment #9109963 - Flags: approval-comm-release?
Attachment #9109963 - Flags: approval-comm-esr60?
Comment on attachment 9109963 [details]
F6 and TAB patch

LGTM
Attachment #9109963 - Flags: review?(frgrahl)
Attachment #9109963 - Flags: review+
Attachment #9109963 - Flags: approval-comm-release?
Attachment #9109963 - Flags: approval-comm-release+
Attachment #9109963 - Flags: approval-comm-esr60?
Attachment #9109963 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/afd0e7a81c04
In standalone mail window F6 and TAB generates error message in console. r=frg

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Whiteboard: SM2.53.1
You need to log in before you can comment on or make changes to this bug.