Closed Bug 1597778 Opened 18 days ago Closed 18 days ago

Firefox doesn't resolve relative-positioning "top" property according to quirks-mode spec

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1259924

People

(Reporter: dholbert, Unassigned)

References

Details

Attachments

(2 files)

STR:

  1. Load attached testcase.

EXPECTED RESULTS:
Div should be 50% of the way down the page.

ACTUAL RESULTS:
Div is at the top of the page.

Chrome and Safari gives "expected results". Firefox and EdgeHTML 18 and IE 11 give "actual results".

I think Chrome and Safari are correct per the quirks-mode spec quirks 3.6 and 3.7:
https://quirks.spec.whatwg.org/#the-body-element-fills-the-html-element-quirk
https://quirks.spec.whatwg.org/#the-html-element-fills-the-viewport-quirk

Summary: Firefox doesn't resolve resolve relative-positioning "top" property according to quirks-mode spec → Firefox doesn't resolve relative-positioning "top" property according to quirks-mode spec

Interestingly, if I use a percent value for height instead of for top (but otherwise leave the testcase unchanged), then we do correctly resolve the percent value against the viewport height.

So perhaps we have these 3.6 - 3.7 quirks partially implemented, via a special case for height that we don't apply for top...?

Ah, I think testcase 2 actually works due to a different height-specific quirk -- specifically 3.5, "The percentage height calculation quirk", https://quirks.spec.whatwg.org/#the-percentage-height-calculation-quirk

And testcase 1 is probably indeed a version of bug 1259924.

Status: NEW → RESOLVED
Closed: 18 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1259924
You need to log in before you can comment on or make changes to this bug.