Closed Bug 1597821 Opened 10 months ago Closed 10 months ago

No content is displayed after calling setViewBackend

Categories

(GeckoView :: General, defect, P1)

Unspecified
All
defect

Tracking

(firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: agi, Unassigned)

References

(Regression)

Details

(Whiteboard: [geckoview:m1911])

Attachments

(1 file)

Pretty much title. After calling setViewBackend, no content is displayed. This is because we don't add the new view to the tree. I thought I fixed this but apparently I landed a version without this fix, patch incoming.

Regressed by: 1530402
Priority: -- → P1
Whiteboard: [geckoview:m1911]
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8a22e5cb6f29
Actually replace view when calling GeckoView.setViewBackend. r=snorp
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.