Closed Bug 1597844 Opened 10 months ago Closed 10 months ago

<input type="date"> (and form control validation tooltips) open at top left (should be bound to textbox) and doesn't close if date entered directly

Categories

(Toolkit :: XUL Widgets, defect, P2)

Unspecified
All
defect

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 + verified

People

(Reporter: aryx, Assigned: ntim)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Regressed by bug 1576946 (= only affects Firefox 72)

<input type="date"> opens at top left (should be bound to textbox) and doesn't close if date entered directly

  1. Go to https://developer.mozilla.org/en-US/docs/Web/HTML/Element/input/date
  2. Click onto the date picker on the right.

Actual result:
Datepicker opened at top left.

Expected result:
Datepicker opens adjacent to input box.

  1. Click outside the textbox.

Actual result:
Datepicker doesn't close.

Expected result:
Datepicker closes.

  1. Press Esc to close the datepicker
Flags: needinfo?(ntim.bugs)

[Tracking Requested - why for this release]: Busted form controls are no good.

Priority: -- → P2

I found where the issue was, patch incoming.

Assignee: nobody → ntim.bugs
Flags: needinfo?(ntim.bugs)
Duplicate of this bug: 1597967
Summary: <input type="date"> opens at top left (should be bound to textbox) and doesn't close if date entered directly → <input type="date"> (and form control validation tooltips) open at top left (should be bound to textbox) and doesn't close if date entered directly
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/30248fce0f93
Fix positioning of form validation and date/time input popups. r=mconley
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Component: Layout → XUL Widgets
Product: Core → Toolkit
Flags: qe-verify+

Confirmed issue with 72.0a1 (2019-11-19) on Windows 10.
Verified fix with 72.0b5 on Windows 10, Ubuntu 19.04, macOS 10.15

Status: RESOLVED → VERIFIED
Flags: qe-verify+
OS: Unspecified → All
You need to log in before you can comment on or make changes to this bug.