Closed Bug 1597961 Opened 9 months ago Closed 9 months ago

Sync is still OFF after choosing to "Sync this device" from about:welcome

Categories

(Firefox :: Firefox Accounts, defect)

Desktop
Windows 10
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: stefan.deiac, Assigned: vladikoff)

References

(Blocks 1 open bug)

Details

Device:

  • Windows 10 - x64bit;

Build:

  • 71.0b11 (64-bit);

Steps to reproduce:

  1. Launch Firefox with a new profile;
  2. Navigate to about:welcome page;
  3. Enter an already registered email address and click the "Continue" button;
  4. Type a valid password and click "Sign in" button;
  5. Click on "Sync this device" button;
  6. Navigate to about:preferences#sync and check the Sync value.

Expected results

Sync is turned ON by default.

Actual results

Sync is turned OFF by default.

Notes

  • I think this is a server issue since I was not able to reproduce this issue on the preliminary testing 2 weeks ago.
  • Also, it seems that the ticket: https://github.com/mozilla/fxa/issues/3083 may be responsible for this issue since the "Enable Sync" button from the choose what to sync panel is not triggered, the sync flow doesn't start.

Vlad, can you please take a look and see if this is caused by the Fxa server changes referenced above?

Flags: needinfo?(vlad)

Thanks for the report , looking into it...

Assignee: nobody → vlad
Flags: needinfo?(vlad)

Fix should be live, try now...

Flags: needinfo?(stefan.deiac)

Hello, retested now and the issue is not anymore reproducible.
Due to that, I'll close this ticket, thanks.

Status: NEW → RESOLVED
Closed: 9 months ago
Flags: needinfo?(stefan.deiac)
Resolution: --- → FIXED

Verified on the 1.150.5v of the production server.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.