Browser window doesn't remember window position

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: jimmys, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

When I close the browser and reload it, Mozilla doesn't remember the window
position.

Reproducible: Always
Steps to Reproduce:
1. Start Mozilla
2. Position browser window
3. Close Mozilla
4. Restart Mozilla, note that browser window is not where you left it.

Actual Results:  Browser window is at the default location

Expected Results:  Browser window should be in the same position it was last time

I searched all the bugs, and it looks like all of the one regarding window
position are closed as duplicates. However, I couldn't find one that matched
what was going on here, so I created a new bug. Apologies if this is a dupe.

Running 1.1beta (as the build ID indicates)

Comment 1

17 years ago
WFM 2002081209 (Windows 2000).

Reporter, can you try with a newer build?

Updated

17 years ago
Summary: Mozilla doesn't remember window position → Browser window doesn't remember window position
(Reporter)

Comment 2

17 years ago
Using 2002081204 on WinXP I see same behavior.

I tried a newer build, but it screwed up my profile so bad I uninstalled it.
(Reporter)

Comment 3

17 years ago
Correction - I see different behavior. It seems the browser window is restored
to correct position every other time it is launched.

I launch Mozilla, it starts in UL corner. I move it to desired position.
Close Mozilla. Start Again, it is in desired position. Close Mozilla. Start
again. It is in UL corner. Repeat...
(Reporter)

Comment 4

17 years ago
Using 1.1-latest (20020818) on Win32, it seems this bug has been fixed for me.
Can others confirm?
(Reporter)

Comment 5

17 years ago
Ok, on a Win2k machine, running 20020823 (from 1.1-latest) and it doesn't
remember the position.

What is going on here?

Comment 6

17 years ago
Uninstall. Reinstall. Create a new profile. Run that profile and see
what happens.
(Reporter)

Comment 7

17 years ago
I'll try to do this soon when I get some time.

In general I am irritated by the lack of interest in maintaining profile
compatibility/integirty evidenced by mozilla. It seems there exists a disregard
for the average user who just wants things to work. I don't know how many times
I have had to rebuild my profiles since I started using Mozilla fulltime at M18.
I can't be the only one that has these problems, and I can't be the only one
that cares about it.

I started this profile clean in 1.0 around 2 months ago. What could possibly be
wrong with it?

Comment 8

16 years ago
in theory, "the average user" isn't supposed to be using mozilla, they should be
using netscape or something else aimed at end users. having said that, the
screwyness with profiles isn't good. however, reports like this aren't really
helpful in improving it - developers need to know what breaks things, not that
it doesn't work when it's broken.

resolving WORKSFORME. if you can reproduce the problem with a recent build of
mozilla, please reopen this bug. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.