Closed Bug 1598511 Opened 1 year ago Closed 1 year ago

Don't die if Subprocess can't chdir to workdir on OpenBSD

Categories

(Firefox :: Extension Compatibility, defect)

71 Branch
All
OpenBSD
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 73
Tracking Status
firefox73 --- fixed

People

(Reporter: jcs, Assigned: gaston)

References

Details

Attachments

(2 files)

With OpenBSD's veiled filesystem (see #1580271), the workdir of a Subprocess may not be visible, but the path to the actual executable being executed is.

In the case of 3rd party extensions like KeepassXC which need to execute /usr/local/bin/keepassxc-proxy, the Subprocess module sets a workdir of /usr/local/bin and then tries to chdir to it before executing. This fails on OpenBSD because Firefox doesn't have read access to /usr/local/bin, but it may (if the user added it) have access to execute /usr/local/bin/keepassxc-proxy.

So on OpenBSD, do not error if the chdir fails.

See Also: → 1580271

Comment on attachment 9110731 [details] [diff] [review]
patch-toolkit_modules_subprocess_subprocess_worker_unix_js

Who would be a good reviewer for that ?

Attachment #9110731 - Attachment is patch: true
Attachment #9110731 - Attachment mime type: application/octet-stream → text/plain
Attachment #9110731 - Flags: feedback?(gpascutto)

:kmag, since this is your code, do you remember the need for the chdir() ?

Flags: needinfo?(kmaglione+bmo)
Comment on attachment 9110731 [details] [diff] [review]
patch-toolkit_modules_subprocess_subprocess_worker_unix_js

I don't know this code so I can't help.
Attachment #9110731 - Flags: feedback?(gpascutto)

Andrew, any hint ? just so that we know if this is something that could go away on all platforms..

Flags: needinfo?(andrew.swan)
Assignee: nobody → landry
Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6b1e007558d2
don't die if Subprocess can't chdir to workdir on OpenBSD r=kmag
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73

Looks like Kris addressed this over on Phabricator...

Flags: needinfo?(andrew.swan)

(In reply to Andrew Swan [:aswan] from comment #8)

Looks like Kris addressed this over on Phabricator...

Flags: needinfo?(kmaglione+bmo)
You need to log in before you can comment on or make changes to this bug.