listing too long when no font available

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: brant, Unassigned)

Tracking

Trunk
x86
Windows XP
Bug Flags:
blocking1.3a -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020728
BuildID:    2002072808

In Appearances > Fonts, if no font is available, it lists "No fonts available
for this language", however, the default size of the preferences dialog prevents
the complete text from being visible.

Reproducible: Always
Steps to Reproduce:
1. Open the preferences dialog.
2. Go to Appearances > Fonts.

Actual Results:  If "No fonts available for this language" appears, it is
concatenated.

Expected Results:  It should not be contatenated.
maybe we should shorten the text to "No fonts available". 
Target Milestone: --- → mozilla1.2beta
(Reporter)

Comment 2

16 years ago
If "no fonts available" fits, lets use it.
(Reporter)

Comment 3

16 years ago
This is a rather simple and safe fix.  Just shorten the string in JS or XUL,
wherever it occurs.
Flags: wanted1.3a?

Comment 4

16 years ago
We're not going to hold 1.3a for this.

(The "wanted1.3a" flag has been changed to "blocking1.3a" to more accurately
reflect how the flag is used by drivers@mozilla.org). 
Flags: blocking1.3a? → blocking1.3a-
Product: Browser → Seamonkey
Assignee: bugs → prefs
QA Contact: bugzilla
(Filter "spam" on 'prefs-nobody-20080612'.)
Assignee: prefs → nobody
QA Contact: prefs
Target Milestone: mozilla1.2beta → ---

Comment 6

6 years ago
Is this issue still actual?
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INCO]
(Reporter)

Comment 7

6 years ago
I do not currently use Seamonkey, but it appears that font inclusions in Windows and/or redesigns of that dialog in Firefox contribute to that issue at least not occuring out of the box. One font type showed as simply a blank for User Defined, so I imagine that's what it'd do if you didn't have a font. So I'm unable to reproduce the issue in Firefox on Windows 7.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INCO] → [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.