Closed Bug 1598770 Opened 3 months ago Closed 3 months ago

Extension Block Request: New Tab Add-on's Collecting Data

Categories

(Toolkit :: Blocklist Policy Requests, task)

task
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: aliceg-85, Assigned: TheOne)

Details

Attachments

(1 file)

Extension name New Tab Add-on's Collecting Data
Extension versions affected <all versions>
Platforms affected <all platforms>
Block severity hard

Reason

These extensions are collecting all kinds of data and storing them in the extension storage. There is at no time a way of opting out/in for this data collection.
The extensions are using a content to pull in this information. The New Tab page is posting a message and based on the response sends a message to the background page with a whole lot of data. You can see the data in the extensions local storage. Cookies are also being used in these extensions. You are able to see all the data by looking in the add-on's local storage.

content.js file:
function syncFromHostedListener(){
chrome.runtime.sendMessage({task: "sync", storage: JSON.stringify(localStorage)});
}

background.js file:
case "sync":
if (request.storage) {
var webPageData = JSON.parse(request.storage);
for (var key in webPageData) {
if (webPageData.hasOwnProperty(key)) {
setPersistStorage(key, webPageData[key]);
}
}
} else {
syncLocalStorage(sendResponse);
return true;
}
break;

Extension IDs

Coupon_Club_App_clone_dMsjQwVamC@www.couponclubapp.co
Access_My_Inbox_zPsghWWAPc@www.accessmyinbox.com
Accurate_Weather_Today_clone_zpRLPSpMcU@www.accurateweathertoday.com
Check_News_clone_qPYbwwKpgF@www.checknews.co
Coupon_Saver_Plus_GTTzegkxqL@www.couponsaverplus.co
Daily_Recipe_Ideas_clone_xqrPqfTBif@www.dailyrecipeideas.co
Fast_Mail_Tab_clone_LPzCObgNLo@www.fastmailtab.com
FileConvertPro_clone_gDJuPpeLjD@www.fileconvertpro.co
Find_Templates_Quick_LyRzafuNXE@www.findtemplatesquick.com
Holy_Bible_Daily_clone_TdHKbGqxyp@www.holybibledaily.com
Live_Inbox_clone_HSqMlnurhx@www.liveinbox.co
Map_Finder_Online_clone_vxRStAVXsj@www.mapfinderonline.com
My_Mail_Center_clone_JJSlJDujLf@www.mymailcenter.co
NewsTrackr_clone_vJczLpOPSO@www.newstrackr.co
Quick_Maps_pjWqGYHPRE@www.getquickmaps.com
Satellite_Maps_Now_aPVhlrXyLu@www.satellitemapsnow.com
Smart_File_Converter_clone_BVgFKwVsaS@www.smartfileconverter.com
Track_Package_Quick_clone_zTowhYQtBK@www.trackpackagequick.com
Travel_Directions_clone_FfMthspRaM@www.traveldirections.co
Weather_Online_Now_clone_VEajkSqfLm@www.weatheronlinenow.com
Web_Gamer_World_clone_bBqNIFWIiJ@www.webgamerworld.com

Additional Information

couponclubapp.co
accessmyinbox.com
accurateweathertoday.com
checknews.co
couponsaverplus.co
dailyrecipeideas.co
fastmailtab.com
fileconvertpro.co
findtemplatesquick.com
holybibledaily.com
liveinbox.co
mapfinderonline.com
mymailcenter.co
newstrackr.co
getquickmaps.com
satellitemapsnow.co
smartfileconverter.com
trackpackagequick.com
traveldirections.co
weatheronlinenow.com
webgamerworld.com

Assignee: nobody → awagner
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

This add-on violates Mozilla's add-on policies by collecting ancillary data and/or by overriding search behavior without user consent or control.

The block has been pushed.

Group: blocklist-requests
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Full list of blocked add-ons

Hey,

We are working quickly to update our add-on to resolve the policy issues that you’ve pointed out. I want to assure you that our intent has always been to operate with good faith, within the policies and we are committed to doing so going forward.

Although we now understand that we were mistaken, our understanding at the time was that we were within the policy guidelines. Since we seem to have misunderstood that, we kindly ask for your guidance and feedback to ensure that we are in compliance going forward.

We’ve followed up with more details to amo-admins@mozilla.com. In addition, we have an updated add-on ready that we believe resolves the policies issues point out. We would like to submit that add-on for review.

Can you please review and give us feedback on the best way to proceed?

Flags: needinfo?(awagner)

This is not the right place to discuss blocklisting appeals and we have already replied to you on amo-admins. Please see the updated thread there. Thank you.

Flags: needinfo?(awagner)

Sorry for the confusion. We didn't see the email reply when we posted this. We will respond back privately via email.

You need to log in before you can comment on or make changes to this bug.