Closed Bug 1598974 Opened 3 years ago Closed 3 months ago

Watchpoint buttons are difficult to see when the object inspector property is highlighted

Categories

(DevTools :: Debugger, enhancement, P3)

enhancement

Tracking

(firefox109 fixed)

RESOLVED FIXED
109 Branch
Tracking Status
firefox109 --- fixed

People

(Reporter: jarilvalenciano, Assigned: karntino.c.areros)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(2 files, 4 obsolete files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.97 Safari/537.36

Steps to reproduce:

  1. Open http://janodvarko.cz/tests/debugger/watchpoints/
  2. Click the button in Test Case #1, direction #2
  3. Add a watchpoint (set/get) to the person's age property in the Scopes pane
  4. Click on the age property to to highlight it

Actual results:

The watchpoint button (either set/get) blends into the highlighted background

Expected results:

The watchpoint button should stand out from the highlighted background

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Inspector
Product: Firefox → DevTools
Component: Inspector → Debugger

Feels like a good first bug.

Honza

Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: good-first-bug
Priority: -- → P3
Assignee: nobody → karntino.c.areros
Status: NEW → ASSIGNED

I'm sorry, I've been making mistakes. I created new ones instead of updating the revision. Apologize for any confusion.

Attachment #9171387 - Attachment is obsolete: true
Attachment #9171131 - Attachment is obsolete: true
Attachment #9170896 - Attachment is obsolete: true

This good-first-bug hasn't had any activity for 2 months, it is automatically unassigned.
For more information, please visit auto_nag documentation.

Assignee: karntino.c.areros → nobody
Status: ASSIGNED → NEW

Hey, what's the status of this bug, I would like to take this up if possible

Yes, please, thank you for the help

I think that the border of the watchpoint button should be white.
(and the background can use the same color as the highlight?)

Honza

Assignee: nobody → avikpaulsept2002
Status: NEW → ASSIGNED
Has STR: --- → yes

This good-first-bug hasn't had any activity for 2 months, it is automatically unassigned.
For more information, please visit auto_nag documentation.

Assignee: avikpaulsept2002 → nobody
Status: ASSIGNED → NEW

Hi my name is Leslie and I'm an Outreachy applicant. Can I work on this bug?

Flags: needinfo?(odvarko)

Yes, thank you for helping.
Assigned to you.

Assignee: nobody → lesore0789
Status: NEW → ASSIGNED
Flags: needinfo?(odvarko)

This good-first-bug hasn't had any activity for 2 months, it is automatically unassigned.
For more information, please visit auto_nag documentation.

Assignee: lesore0789 → nobody
Status: ASSIGNED → NEW

Hi :Honza, I would like to work on this issue.

Assigned to you, thank you for helping.

Honza

Assignee: nobody → goodnesschrisugari
Status: NEW → ASSIGNED

:Honza, I made the watchpoint markers' borders bolder to make it more obvious when highlighted, tried to make the border white when highlighted but nothing seems to be working, any ideas?

Attachment #9246359 - Attachment is obsolete: true

This good-first-bug hasn't had any activity for 2 months, it is automatically unassigned.
For more information, please visit auto_nag documentation.

Assignee: goodnesschrisugari → nobody
Status: ASSIGNED → NEW
Severity: normal → S3

Hello,
If this bug is still open, I would like to work on it please.

Assignee: nobody → karntino.c.areros
Status: NEW → ASSIGNED

(In reply to Akshya Krishnan from comment #20)

Hello,
If this bug is still open, I would like to work on it please.

Hello Akshya, Goodness Chris-Ugari already had working patch for this that I forgot to land (but will try to today), sorry

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ef7f28997097
slightly changes the color of the watchpoint markers when highlighted. r=nchevobbe

Hi Akshya,
Are there other good first bugs you are interested in? You can check here for other good first bugshttps://codetribute.mozilla.org/projects/devtools?tag%3Dgood-first-bug

Flags: needinfo?(akshyakrish92)
Flags: needinfo?(akshyakrish92)
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 109 Branch
You need to log in before you can comment on or make changes to this bug.